Problems Setting Special Static ips on Neth Server 7

Hello I am having issues with my old neth server 6.8 machine so i am in the process of moving things over to the new server…

This below is the public ip or the red zone
So here is how it goes…
ifconfig ens19 netmask
sleep 2s
route add dev ens19
route add default gw ens19

If I run this script my server just works however I can’t get the Web Ui to set this information…!Ann6Dvc7oI7et28qDKHB7C6NtKic

Now i have actually provided real information here so please if you got the time explain how am i suppose to set this up properly on Neth 7???

I am getting very frustrated with this…

My gut feeling says me that this scenario is not possible through the admin webinterface. Having a GUI is always a tradeoff between complexity and functionality. You managed to get it done through the commandline. I think this is the only way it can be done right now.
It would be good to document this on a wikipage.


I still think their needs to be a better work around or some modifications in the web ui for these special ip situations… In my case this is required for OVH data centers they can’t be the only ones in the world that do this sort of thing…

Here is a working example that just works for me… I use this on one of my emergency communications server and backup repeater control server it is a debian os but here is what it looks like…

    root@uhf:~# cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    #source /etc/network/interfaces.d/*
    # The loopback network interface
     auto lo
     iface lo inet loopback
    # The primary network interface
     allow-hotplug eth0
     iface eth0 inet static
     post-up route add dev eth0
     post-up route add default gw
     pre-down route del
     pre-down route del gw

Why can’t i do the same thing in Neth Server 7?? Where do i place this info??

So any thoughts on how to fix this?? Or at least disable the we ui from latching onto the network card and changing the information incorrectly?

@dev_team Can somebody help?

It’s really hard to customize the network part, I would go with a more standard VPS/virtualizator.

Well… I rent t he Rack server and use proxmox virtualization to make things happen however I don’t understand how or why you guys would block the input of customized ip setup… If anything just have a check box to allow users to customize their ip segments as they need not leave them out to dry…

Typically speaking i usually just edit in my debian distors /etc/network/interfaces and inside their i put what i need and things just work no issues… I don’t understand how centos could be that much different however i have noticed stupid changes that cause this not to work and not sure if its neth or centos in general…

Hi Loren,
I’ve found a site with an explanation where to find network settings:

I think it’s Nethserver, it overrides settings which are made manually without a custom template.
@giacomo Can’t he do it with config setprop…?

You can’t change such behavior with a setprop.

It’s not the CentOS behavior, but the NethServer one.
NS needs to handle the whole network stack to configure all installed software and the firewall rules.

1 Like

Ok… So what can be done? I hard code the mac address in proxmox so that is solved and seem to work just fine in that respect… The issue with the networking still blows my mind why Neth 6 works great with no issues but Neth 7 literally fails and falls flat on its face…

What could have been that drastic between your changes with in Neth?

In NS7 the MAC address is ignored for network interface naming, since upstream changed naming conventions.


I am not sure how… But I was able to get Neth 7 running however I am very gun shy to put it in service right away especially after my past experience as you can see we do have network etc… Any advise on transferring files from the old server to the new one? Especially certificates and vpn certificates if they are different…

Below is the installation

Here is what i have done…
nano /etc/rc.local
add line
sh /root/

Then I created a in root

ifconfig ens18 netmask
sleep 2s
route add dev ens18
route add default gw ens18

So… We will have to see how this goes when i put my real ip in their with the same gateway which is…

1 Like

For openvpn you have to do some work, please have a look: