Problems installing NS 7rc2

NethServer Version: 7.2rc2

I’ve not been around for a while, but I saw the Distrowatch announcement of 7.2 rc2 and wanted to try it. Downloaded without problems, checked the md5, iso is fine. I then used dd to dump it to a flash drive. Attempting to install from that media failed - went through most of the install, then got to the post install tasks. During that phase, the install terminated quite suddenly with “something 4” - flashed past too fast to be noted.

Next attempt, I tried to verify the media using the menu item. Which said it was not a suitable install source, but would not let me back to the menu, since I had added nothing to the URL option on that page of the install.

I then burnt a DVD copy (last DVD that I’ve got on hand), and had the same problem.

I’ve done some searching, but haven’t found any additions to the install instructions, so I’m wondering if I’ve missed something.

This is a bare metal install to a machine I use for testing (which had a Nethserver 6 install previously). Its an HP 8000, Intel core2duo CPU, 6 GB RAM, two NICs, only one in use.

Any hints as to what I’ve done wrong? I’d very much like to try the upcoming verison…

It is very strange, I’ve downloaded today I had no trouble downloading or copying DVDs, much less install

The problem happened from a USB drive and DVD. What error does the installation show

When the install terminates, the machine restarts, and boots to the newly (almost) installed system. I’m able to log in, and run ifconfig to check that there is a network connection. At that point, everything seems ok.

After a minute or two, I get "unable to register logger’ on the terminal. That repeats a number of times. If I then run ifconfig again, neither eithernet interface is seen, all I get is the "lo2 entry. At the same time, the network becomes unreachable.

Its not a hardware problem - I’ve just done a full CentOS 7 install, which is working fine (not a minimal install, unfortunately, since the CentOS copy I had was on a Linux Format DVD - no install options available). That install works fine, so its something in the Nethserver media that is causing the problem.

I’ll see if I can pick up some more blank DVDs tomorrow and try again. Either that or do a minimal CentOS install from the ISO I just downloaded and try installing Nethserver from that.

That message happened to me at the beginning after installing, but update the system and install the packages to make tests and I did not see it again

About the error:

1 Like

@paul_marwick, I think your media is fine. You are probably experiencing another version of the problem I had on virtualbox:

Please, try those commands.


The message is 4m[terminated]

I’d the same problem: upon installation I could ping, then the logger error, after that no connection.
It worked after a reboot.

Thanks for the reply. Tried that …

I’ve only got one interface active at the moment, connected to my home network. My DHCP server gate it After running the db commands, nothing has change at all - IP for the machine is still

I also found that I had no working DNS on the test machine - /etc/resolv.conf listed localhost only. I had to manually add the IP of my DNS server to it before I could update the server, which I did in the hopes it might clear some of the problems. No such luck…

I also tried accessing the server manager, hoping that I could clear some of the issues from it. However, while the http daemon is running, any attempt to access it from other machines in my network fails - using https://< IP >:900 gets me a “connection refused” error, using https://< ip or hostname >/server-manger gets me an untrusted certificate prompt. When I accept the certificate, I get a 404 - server-manger not found.

:frowning: Still struggling, I’m afraid…

Thanks. Thought I’d tried that, but must not have (it was getting late…). That seems to have cleared the loss of network, though I did get a few more “logger” errors. At least that gets me a working network connection.

One problem solved - must have misremembered the port number for the server manager. Once I changed 900 to 980, I was able to access the server manager.

One other problem I’ve hit with my initial install - when I installed again this afternoon, I configured a user as well as setting up the root password. I can log in as that user, either locally or via SSH, but nothing has been copied to /home, so I get an error and I’m dropped in \ . I’ve not yet tried creating users from the server-manager - got to go to work, so I’ll try that tomorrow.