Problem with Nextcloud after Nethserver update 7.5 -> 7.6

NethServer Version: 7.6.1810 (final)
Module: nextcloud 15.0.0-1.el7

Hi group,

Today I decided to execute the update from Nethserver version 7.5 to 7.6 (no weather to be outside anyway :grinning:). I ran into two problems, one of them I could solve by myself (no longer possible to login to Samba-shares, resolved with signal-event nethserver-dc-update and /etc/e-smith/events/actions/system-adjust).

The other problem concerns Nextcloud. When opening the Nextcloud webpage the login-screen does not appear but in stead of that the message “The files of the app External user support (user_external) were not replaced correctly. Make sure it is a version compatible with the server.” is produced. I noticed that version 14 is replaced by version 15. I tried “signal-event nethserver-nextcloud-update” and “yum reinstall nextcloud” but this doesn’t solve the issue. What could I try next?

Seasons greetings! :christmas_tree:

You can try with:

sudo -u apache /opt/rh/rh-php71/root/usr/bin/php /usr/share/nextcloud/occ upgrade

and post the errors if any.

or disable the user_external app:

sudo -u apache /opt/rh/rh-php71/root/usr/bin/php /usr/share/nextcloud/occ app:disable user_external
sudo -u apache /opt/rh/rh-php71/root/usr/bin/php /usr/share/nextcloud/occ upgrade

If no error, re-enable the app and try to login. You can login as Nextcloud’s admin then check for app updates.

1 Like

Hello Marc,

Thanks for the tips on the Nextcloud problem. After executing your commands and digging a little bit deeper, it seems that I struck a known Nextcloud bug:

With the directions in this post (changing the max-version=“14” into “15” in “apps/user_external/appinfo/info.xml”) I was able to get thinks working again. Thanks Marc for putting me on the right track!


The solution don’t work for me. After`

sudo -u apache /opt/rh/rh-php71/root/usr/bin/php /usr/share/nextcloud/occ app:disable user_external
sudo -u apache /opt/rh/rh-php71/root/usr/bin/php /usr/share/nextcloud/occ upgrade`
sudo -u apache /opt/rh/rh-php71/root/usr/bin/php /usr/share/nextcloud/occ app:enable user_external

and changing max-version=“14” into “15” nextcloud stay in the maintenance mode

I made a downgrade for nextcloud and nethserver-nextcloud, now i’m able to login

EDIT: it doesn’t work, i get the message

Downgrading is not supported and is likely to cause unpredictable issues (from to

Hi Klaus,

You can get Nextcloud out of maintenance mode as follows:

sudo -u apache /opt/rh/rh-php71/root/usr/bin/php /usr/share/nextcloud/occ maintenance:mode --off

After that Nextcloud should work as expected again (it did in my case).

1 Like

I made again an upgrade to nextcloud 15.0, now it works

Just as a friendly note, I believe the ‘correct’ RedHat syntax would be:

sudo -u apache scl enable php71 ‘php /usr/share/nextcloud/occ maintenance:mode --off’


1 Like

Thanks, will update the wiki with this information. The correct scl php version name, in this case, seems to be rh-php71.

Interesting one, for SCL will take care of that, and we have modules that use remi(safe) and rh-centos…

hence in /opt you will find remi and rh. I know @stephdl has some more in depth knowledge on this.

We have two php-scl rpm here

This one provides official software collection with low php dependencies, it is for developers, you just provide one version of php without integration

With this rpm you provide php{56,70,71,72,73} with several panels to modify the settings, these are integrated with the virtualhosts and I provide a lot of php dependencies because the target is end user or non skillled sysadmin

This comes from remi-safe due to the huge number of non official software collection.

Remi is one of them who made the software collection, his repo is a laboratory.

1 Like