Problem upgrade packages to 6.7


(Rafael Tavares) #1

I have this problem with yum update

Protected multilib versions: libffi-3.0.5-3.2.el6.i686 != libffi-3.0.10-1.x86_64

Please help…


(Stefano) #2

something is wrong with your repos…

please, start telling us ALL about your setup, any “custom” package installed, repo enabled… you’re trying (I guess, you give us no details) to do something with an i686 rpm that is not supported on NS (only x84_64 is)


(Rafael Tavares) #3

No, only official repo is enable.


(Stefano) #4

well… is should not appen…

please post here the whole yum log (the relevant part), thank you


(Rafael Tavares) #5

I am use yum --setopt=protected_multilib=false update and this complete upgrade, because error aparence in depo resolution and dont log this


(Filippo Carletti) #6

Could you please show the output of:

rpm -q --queryformat="%{NAME} %{ARCH}\n" libffi

And rpm -qi libffi?


(Rafael Tavares) #7

rpm -q --queryformat="%{NAME} %{ARCH}\n" libffi

libffi x86_64

rpm -qi libffi

Name : libffi Relocations: (not relocatable)
Version : 3.0.10 Vendor: (none)
Release : 1 Build Date: Fri 28 Oct 2011 05:19:59 PM BRST
Install Date: Thu 21 May 2015 10:28:34 PM BRT Build Host: vizzini.inverse.c a
Group : System/Libraries Source RPM: libffi-3.0.10-1.src.rpm
Size : 31720 License: Distributable
Signature : DSA/SHA1, Fri 20 Dec 2013 01:16:44 PM BRST, Key ID e23a79e1f25b5f7 0
Summary : A library for interfacing to various calling conventions
Description :
Ffi stands for Foreign Function Interface. A foreign function
interface is the popular name for the interface that allows code
written in one language to call code written in another language. The
libffi library really only provides the lowest, machine dependent
layer of a fully featured foreign function interface. A layer must
exist above libffi that handles type conversions for values passed
between the two languages.


(Giacomo Sanchietti) #8

The mismatched version is due to SOGo dependencies, but if you have all repos correctly enabled, dependencies are automatically resolved.

You can try something like this:

yum downgrade libffi

After the upgrade to 6.7, make sure SOGo still works.


(Giacomo Sanchietti) #9

We were able to reproduce the problem inside another machine, so I just updated the base repository by adding an extra package.

Just wait the mirror near to you is in sync, then restart the update process.

Otherwise, you can disable the mirrorlist and use the baseurl to the master mirror: http://mirror.nethserver.org/nethserver/


(Rafael Tavares) #10

Iam remove VPN packages and later upgrade ok, and reinstall VPN packages and its ok

Thanks