Problem to get access to Webtop Cloud

i think the permissions ar ok.Anmerkung%202019-02-15%20220023

The same permissions are applied also to the files?

Yes. There are the same permissions.

It’s a strange problem.

  • Can you try login with a user without files and see if get the same error?
  • Can you check these properties in Webtop admin properties?
    – com.sonicle.webtop.core - home.path
    – com.sonicle.webtop.vfs - check if there is some properties

Webtop is up to date?

Yes, WebTop is up to date. Tomorrow i will check it with a new user.

Have a nice evening…

1 Like

Hi @transocean,
probably I’ve found the error: if you have a file with character like “:” Webtop goes in error. I suggest you to rename this file and all should be works properly.

In fact:

Probably you have uploaded a file with “:” from SFTP and not from Webtop interface that block the upload. To find files that contains “:” you can use these commands:
find /var/lib/nethserver/webtop/domains/NethServer/com.sonicle.webtop.vfs/mydocuments/*/ -name '*:*'
find /var/lib/nethserver/webtop/domains/NethServer/images/ -name '*:*'

Then you can rename found files with mv command.

If are not “:” you have to search some others special characters.

@lucag @webtop_team Maybe we can add an error description when log contains
[ERROR] com.sonicle.webtop.vfs.Service - Error in ManageStoresTree org.apache.commons.vfs2.FileSystemException: Could not find files in “file:///var/lib/nethserver/webtop/domains/NethServer/com.sonicle.webtop.vfs/mydocuments/myuser”.


Caused by: org.apache.commons.vfs2.FileSystemException: Invalid descendent file name “Y:”.

that suggest to user to contact SysAdmin because there is an error with file names and he have to check it.

Wait for feedback.



Yes, this is a known bug on the Apache Java VFS libraries.
We have solved it in the interface by sanitizing the names when possible, but this is not always under control.
Here was the issue:



Good morning Federico,

there is no file named C:log.text.


The upload goes not via SFTP. I use only WebTop for Upload.
I have created a new user for testing the upload. Upload is also not possible.



I confirm that the problem has been solved and the fix is included in the 5.5.2 release released a few days ago:

I recommend updating and try again :wink:

I have NS new installed from the latest image.
In the previous version 7.5 1804 I did not have the problem.

Good morning lucag,

the latest version of WebTop 5 is already on the server.



1 Like

3 posts were split to a new topic: Changing starter date of a repetitive appointment

@transocean you are checking in the wrong folder.
Use this command and substitute user with your username

find /var/lib/nethserver/webtop/domains/NethServer/com.sonicle.webtop.vfs/mydocuments/user/ -name '*:*'

Obviusly it will not appear a file named C:log.txt… I created this file manually to have some test.

But you receive the error when try uploading or when you try open webtop cloud?

1 Like

In your case there is a file named “Y:”, in fact in log you can see

Caused by: org.apache.commons.vfs2.FileSystemException: Invalid descendent file name “Y:”

Give me feedback. Thank you.


Sorry for the late answer. Server has crashed. New Installation is running.

Yes, there was a file named “Y:”

Ok, if I solve your problem mark this answer as solution that can be helpful for other users.

Thank you.

Lets wait one hour. Maybe the problem will come back.

1 Like

Yes. Update us :slight_smile:

Same problem after fresh installation.

find /var/lib/nethserver/webtop/domains/NethServer/com.sonicle.webtop.vfs/mydocuments/*/ -name '*:*'

Launch this command from SSH and post result.