PhPVirtualBox error

Is it on a new vm or always the same as the beguinning?

Same thing on two machines, on VM and on my NAS.
The same error.

Do I make a new VM?

Other tests:
I created a VM2 and installed VirtualBox from software center.
“YUM Error”.
from terminal I executed the command “yum clean all” and I tried again to make the updates and the YUM always goes in error.

Other tests:
I created a VM3 and installed VirtualBox as QA.
All OK, until access to the web interface.
Then, same mistake as always.

Please do other testers could test to install php virtualbox as the qa of the bug (from nethserver-testing) i cannot reproduce the failing state

definitively I cannot reproduce

yum update -y; reboot

then install the rpm from testing

yum install nethserver-virtualbox-5.2-phpvirtualbox nethserver-virtualbox-5.2-VirtualBox --enablerepo=nethforge-testing

something fun also, you doesn’t have the redirection to https, it is forced, it works on my side, but not on your system

Really I do not understand

I did as you asked.
The YUM problem no longer appears.
The VirtualBox task is activated in the applications section.
Updates work well.
The problem remains when I want to access the web page of the virtualbox.
Admin / admin give an error as if false credentials were used.

  1. I create VMs from a broken template. Unlikely, I tried it on my NAS and the result was the same.
  2. There is some modules that conflicts with the VirtualBox.
  3. I can’t do it, because I’m not as expert as you and I don’t focus on the problem
  4. I don’t know …
1 Like

Not a matter to be expert or not, I simply cannot reproduce your error so I cannot fix it :smiley:

what is your php version (centos7 default is php54)
what is your network schema (one or several nic bridged to a real IP of your network)
do you have installed nethserver-dc or nethserver-directory, admin/admin is when you do not have any account provider

@dnutan @mrmarkuz could try to test and report

yum update -y; reboot

then install the rpm from testing

yum install nethserver-virtualbox-5.2-phpvirtualbox nethserver-virtualbox-5.2-VirtualBox --enablerepo=nethforge-testing

1 Like

I could reproduce the error. If there is no red interface, you’ll get this error, see Phpvirtualbox-5.2 needs testers

[root@testserver ~]# expand-template /usr/share/phpvirtualbox/config.php
ERROR in /etc/e-smith/templates//usr/share/phpvirtualbox/config.php/20SettingsRDP: Program fragment delivered error <<Can't call method "prop" on an undefined value at /etc/e-smith/templates//usr/share/phpvirtualbox/config.php/20SettingsRDP line 21.>> at template line 5
ERROR: Template processing failed for //usr/share/phpvirtualbox/config.php: 1 fragment generated errors
 at /sbin/e-smith/expand-template line 45.

Maybe check if $red has content?

After setting up a red interface and expanding the template it worked:

expand-template /usr/share/phpvirtualbox/config.php


Thank you will try to fix

1 Like

Thank all, could you test again @roberto.schiano @mrmarkuz

yum update -y; reboot

then install the rpm from testing

yum install nethserver-virtualbox-5.2-phpvirtualbox nethserver-virtualbox-5.2-VirtualBox --enablerepo=nethforge-testing

1 Like

It’s working now. After install I could login with admin/admin.

But according to your test case:

go to the software center, you must have no warnings relative to the repository key of virtualbox, do a yum upgrade, yum must not ask to accept the key of the virtualbox repository, it must run smootly and propose directly some upgrades for virtualbox

I was asked for a key when doing the yum update:

Downloading packages:
No Presto metadata available for virtualbox
warning: /var/cache/yum/x86_64/7/virtualbox/packages/VirtualBox-5.2-5.2.32_132073_el7-1.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY=================================================================================    ] 9.3 MB/s |  69 MB  00:00:00 ETA
Public key for VirtualBox-5.2-5.2.32_132073_el7-1.x86_64.rpm is not installed
VirtualBox-5.2-5.2.32_132073_el7-1.x86_64.rpm                                                                                                                                                                                                           |  71 MB  00:00:08
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-virtualbox
Importing GPG key 0x98AB5139:
 Userid     : "Oracle Corporation (VirtualBox archive signing key) <>"
 Fingerprint: 7b0f ab3a 13b9 0743 5925 d9c9 5442 2a4b 98ab 5139
 Package    : nethserver-virtualbox-5.2-VirtualBox-1.0.1-1.9.gc3ad46c.ns7.noarch (@nethforge-testing)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-virtualbox
Is this ok [y/N]: 

do a signal-event software-repos-save after the event the repository must be enabled

virtualbox.repo is enabled without doing “signal-event software-repos-save” manually.


Hi everyone.
My steps:

  1. On ProxMox server I created many VMs
  2. I installed the latest version of Nethserver, made the wizzard and only updated it.
  3. The PhP is definitely the default one.
  4. The NIC is definitely in bridge, it is a virtual machine. But on my NAS it is a physical NIC with its own IP of the LAN
  5. I manually installed the PhPVirtualBox as written in QA.
  6. I have not installed any account providers.
  7. I only have one NIC (green), both on the VMs and on the NAS
1 Like

I did it all over again.

  • new ProxMox (ver 6)
  • new VMs
  • executed the last manual commands

Everything works, even on my NAS.

Now another problem:

All the proposed operating systems are 32 bit …

Limitation of a virtualisation over an virtualisation

1 Like

Could you mark this thread as solved please.

OK. I tried on my NAS, 32 and 64 OK

1 Like

Seems an issue from the CPU… Not all support nested VT x64 virtualization

1 Like

released, really thank you mates


Updating system work for me.