PhPVirtualBox error

in the documentation I stated your kernel must be up to date before to reboot on the last kernel, this is due to the lack of kernel-devel for old kernels, rhel keeps only some rpm, unfortunately not all

[root@ns7loc14 ~]# rpm -qa | grep kernel

[root@ns7loc14 ~]# /sbin/vboxconfig Stopping VirtualBox services. Starting VirtualBox services. Building VirtualBox kernel modules.

OT but I find another bug @roberto.schiano

thank :slight_smile:

I am a bit lost, you made several attempts, for what I saw, here you should be able to login with the user admin and password admin, does it works on your server ?

In the mean while I solved the error of software center you described

could you test please

yum install

could you please give the output of config show phpvirtualbox

Please @roberto.schiano, do not post screenshots of putty.
Copy and paste the output on the thread, using the
right tool
to format the output

1 Like

The right format could be a [code] Tag

Hi… So, I’m clear …
I have a ProxMox server where I do my tests and when I find a problem and I delete VM end restart …
Now I’ll do it all over again and then I’ll update you.
Thank you

  1. VM created
  2. updated so far
  3. installed the PHPvirtualbox package from the list of available packages
  4. end of installation and I receive in YUM the following two errors:

Resolving RPM dependencies

failure: repodata/repomd.xml from virtualbox: [Errno 256] No more mirrors to try. [Errno -1] repomd.xml signature could not be verified for virtualbox

Then from teminal, execute this:

yum install

This is the result from putty…:crazy_face:

the problem always exists or I make a mistake, but which one?

Sorry. the last putty image…

1 Like

So… the phpvirtualbox dasen’t work

you cannot install my rpm because yum doesn’t understand it is an upgrade, so you must remove them, a quick way is

rpm -e --nodeps nethserver-virtualbox-5.2-phpvirtualbox nethserver-virtualbox-5.2-VirtualBox

then install them like I asked but but but in fact my rpm build by travis have disappeared, I will push them to testing


please testing QA

OK done…
All steps are OK.

Only problem that remains after accessing the virtualbox as admin / admin:

Exception Object
    [message:protected] => Error logging in to vboxwebsrv.
    [string:Exception:private] => 
    [code:protected] => 64
    [file:protected] => /usr/share/phpvirtualbox/endpoints/api.php
    [line:protected] => 134
    [trace:Exception:private] => Array

    [previous:Exception:private] => 

Is it on a new vm or always the same as the beguinning?

Same thing on two machines, on VM and on my NAS.
The same error.

Do I make a new VM?

Other tests:
I created a VM2 and installed VirtualBox from software center.
“YUM Error”.
from terminal I executed the command “yum clean all” and I tried again to make the updates and the YUM always goes in error.

Other tests:
I created a VM3 and installed VirtualBox as QA.
All OK, until access to the web interface.
Then, same mistake as always.

Please do other testers could test to install php virtualbox as the qa of the bug (from nethserver-testing) i cannot reproduce the failing state

definitively I cannot reproduce

yum update -y; reboot

then install the rpm from testing

yum install nethserver-virtualbox-5.2-phpvirtualbox nethserver-virtualbox-5.2-VirtualBox --enablerepo=nethforge-testing

something fun also, you doesn’t have the redirection to https, it is forced, it works on my side, but not on your system

Really I do not understand