PHABRICATOR on NS

I’m pretty sure the $ shouldn’t be here, or in the other places it’s appearing. Check your template files.

2 Likes

@danb35 long time no see.

could work on converting this into a module?
what do you say? it gave us some hell, time to simplify the process right!

I don’t have enough interest in this software to put in that effort.

i would like then to know how to build modules.
build repos
and similar.

just came across this. maybe it can be re-purposed and tuned. for centos, and for nethserver integration.

Here are some links with info on creating a module:


2 Likes

been trying to install the system using the wiki here: https://wiki.nethserver.org/doku.php?id=ht_phabricator

but i guess there are many changes that need to be considered.

cd phabricator
bin/config set mysql.pass $(cat /var/lib/nethserver/secrets/mysql)

running the comman, i get the error:
UPGRADE PHP: The installed version of PHP ("5.4.16") is too old to run Arcanist. Update PHP to at least the minimum required version ("5.5.0").

You need to install nethserver-php-scl for this howto.

i began with that process, but still get the same error

The problem is that PHP54 is found instead of the newer version.

/etc/httpd/conf.d/virtualhosts.conf should have following line to use PHP72 from php-scl:

SetHandler "proxy:fcgi://127.0.0.1:9072"

Maybe you missed to reload the httpd service.

this is what is listed:
#
# 10default_vhost
#

IncludeOptional conf.d/default-virtualhost.inc

#
# 20virtual_hosts – expand extra virtual hosts
#

Seems the following step didn’t work. It should write your template fragment to the config file. Do you get an error?

expand-template /etc/httpd/conf.d/virtualhosts.conf

no errprs

Does /etc/e-smith/templates-custom/etc/httpd/conf.d/virtualhosts.conf/15_phabricator exist and does it have the right content?

av not yet gotten to that point, so the file is nonexistent. i was at the first steps of installation.

Please try the following before the bin/config:

source scl_source enable php72

https://wiki.nethserver.org/doku.php?id=php-scl#use_the_php_cli

that one worked.

updated the wiki.

1 Like

this portion of $domainname

is the dollar sign needed?

image

Yes:

its contents should be as below:

and the name

$DomainName

should it remain that way, or should be replaced with $mydomain.tld