OpenVPN question about route-nopull route-noexec

NethServer Version: NethServer release 7.3.1611 (Final)
Module: OpenVPN


First of all i want to say thanks to the nethserver developers
Ggreat job
i switched from zentyal, and i like it a lot more :slight_smile:

I wanted to create a bridge mode OpenVPN connection, the server is also configured to run as an AD DC

When i connect with my linux client i get a route of with a gateway of metric 50 dev tap0.

I can not disable this by no means from the client config , i tried route-noexec route-nopull , none worked.

Is the client trying to use redirect gateway ?
Could anyone tell me what is happening ?

When i add a new default GW everything just works as intended.

on client after connecting :
[root@VPNclient ~]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 50 0 0 tap0

then i do :
route add default gw (this is my wireless router my real default gateway)
and everything works as it should.

Does it automatically uses redirect-gateway ? Does it deny route-noexec or route-nopull ?
Or is my linux client doing something strange , blaming systemd btw.

Thanks a lot for making nethserver :slight_smile:
I will try to help if i can

All messages welcome
Best wishes to all

Did you find a solution?
Do the new OpenVPN tunnels feature help it?

The redirect option must be explicitly enabled.
If you have doubts, please check the configuration file under /etc/openvpn/host-to-net.conf