Openvpn problem


You have found any problem with my configuration?

is this the connection that doesn’t work? have you installed the dns/dhcp package of nethserver? have you set in your router/firewall ( i presume) a static route rule ( from to ?

Yes, is this
No, dns/dhcp package is not installed
The router is
No, don’t have any static route

try to add a static route rule on your router something like OpenVPN network: => next hop nethserver ip

When I am connected I can access the NethServer (
I can not access any other box in my home network and I can not access the internet

The static route does not work.
I will try witk the dns/dhcp package installed

Installed and configured dns/dhcp package.
Continue to work as before.

You can ping ip that are in your network? and what about internet ip?

Sorry for the delay

I can ping or access only the NethServer in my network -

In the internet i can ping or access the server by IP - ( - DNS servers) or ( -
I can not access any site by name in the internet - or

ok there seem to be two different problems:

this is a routing problem

and this is a dns problem

So for the dns one you can try to remove dns/dhcp package from nethserver.

Instead for the routing problem we have probably to make some debug…can you write the topology of the network where nethserver is located?

I already tried with and without the dns/dhcp package.

Router - with DHCP/DNS. It is not possible to disable the DHCP or DNS (the router is from my ISP)

NethServer - 1 NIC - (static IP) and dns/dhcp package configured with the folowing DNS and The DHCP server from NethServer is not enabled
Already tried with the router’s DNS ( but without success.

3 workstions geting the IP from the router


Can you reproduce the problem?

Sincerly no, i’ve no problems with vpn if i disable dns package and put a static route on my firewall… @giacomo @filippo_carletti you?


Ok, I will try your configuration.

I plan to start using the email server in the next week.
When I install the email server without the DHCP/DNS package installed I have an error related with dnsmasq.
The email server will work well without the DHCP/DNS package installed?


Great, it works

I did some mistake in the first time I tried.
The email server will work well without the DNS package?

Many thanks

1 Like

Yes of course it will work

Many thanks

1 Like

I have a similar problem
OpenVPN don’t want to start
I don’t have DHCP/DNS service dnsmasq

OpenVPN pointing out this config : push “dhcp-option DNS,” it don’t like the ,

I’d specified 2DNS into config server : and
I took a look into /etc/resolv.conf, /etc/sysconfig/network, /etc/sysconfig/network-scripts/ifcfg-eth0 and /etc/sysconfig/network-scripts/ifcfg-eth1 but I can’t find from where coming.

##this is /etc/openvpn/host-to-net.conf
push "dhcp-option DNS"
push "dhcp-option WINS"
push "dhcp-option NBDD"
push "dhcp-option DNS,"
push "dhcp-option WINS,"
push “dhcp-option NBDD,”

when I try to remove the , and restart openvpn it come back “nethserver-openvpn-save”

Anybody know how I could find from where coming this 3rd ghost DNS and/or how I could force my own push dhcp-option DNS ??

I think there are 2 improvements that can be done to have a fully funcional openvpn server

1 - At the moment is only possible to access the server who as the openvpn configured. If we need a service in another box its necessary to configure another openvpn server in that box.
it’s better to have access to the other services in the network from the openvpn who is configured

2 - Ability to configure the dns servers that the client will use. At least 2 dns servers

Pls, check your OpenVPN settings. It works without DHCP/DNS service dnsmasq