NS8 on debian12 no login

NethServer Version: 8
Module: debian12
Hello again,
tried to install Nethserver 8 on debian12 as VM on Proxmox like write on NS8 documentation

curl https://raw.githubusercontent.com/NethServer/ns8-core/ns8-stable/core/install.sh | bash

After correction of network installed a lightweight desktop openbox for simple administration of NS8

apt install openbox epiphany-browser xinit
apt clean
df -Th

Started browser and tried to login as admin at https://localhost/cluster-admin/
But system don’t like the official password Nethesis,1234
Second time started another VM ubuntu 22.04 and tried to login via https://(IP of NS8)/cluster-admin/ but the same problem …

Cannot log in Invalid username or password

Logging in as admin Not you?

Is it an error of mine ? or how to correct this ?


AFAIK, you can’t install a Desktop on top of NS8, then install NS8 and expect it to work.
I had NO problems last week following the instructions to install and update NS8. Login worked.

I did not read any ot this on the instructions here:


Maybe just follow the instructions to the letter!

This makes NO sense!
Do you expect to be able to login on a vanilla Ubuntu using the Cluster-Admin login? NS8 won’t run on Ubuntu, AFAIK!

Just follow the instructions, it works easily on Proxmox!

You need to use a second box to administrate the whole thing, Proxmox, Debian12 and NS8.

My 2 cents

Thank you, Andy_wismer,
…there is a missunderstandness.
I installed NS8 on a debian-VM on Proxmox.
Then tried to login from a second ubuntu-VM. Never tried to install NS8 on ubuntu !
But there’s no login possible. Thatswhy I tried to login at localhost via openbox…epiphany-browser

It seems your Network is missing some stuff, like DNS, correct DHCP, etc…

You should have working internal DNS when setting up NS8, and you should use a working FQDN for NS8.

See here:

Worked for me…

My 2 cents

Good evening,
I used this too, I thought… make it again :
Installed debian12 from ISO deb12-bookworm-mini-x64.iso / only basic ssystem!
2 users root and admin with password Nethesis,1234
Static IP via DHCP server on Firewall
… and now it’s possible to login from a second VM … looking for the next pitfall
Can’t remember what’s wrong at the first try … first time I used other passwords !

Hi @rowihei,

the passwords of your Debian users should not matter. It must have been something else that went wrong in your first try.
For a system reachable from the Internet, you should definitely use more secure passwords for your Debian system accounts.

And 2FA for more Safety.