NS8: Migration worked well except of DokuWiki, File Server and direct migration to node2


  • 2 Proxmox VMs on 2 Proxmox nodes for the NS8 nodes
  • 2 NS8 nodes with Debian 11.7.0 installed from ISO
  • 1 NS7 Proxmox VM with ejabberd, mail, file server, mattermost and roundcube webmail


  • Migrating directly to node2 didn’t work, the apps were always on node1 :x:
  • Moving them to another node afterwards works :white_check_mark:
  • If you move an app to another node you need to change the DNS entry to the right IP of the new node


Mattermost :white_check_mark:

Mail Migration included Roundcube and Webtop.

Roundcube :white_check_mark:

  • Roundcubemail-next isn’t working because the migration searches for the database in mysql 5 and fails
  • the old LTS version works
  • no contacts in addressbook before migration of local AD, maybe issues with remote AD?
  • Mail send/receive worked

Webtop :white_check_mark:

  • The Webtop path is still there, like https://webtop.domain.tld/webtop

Ejabberd :white_check_mark:
Active Directory :white_check_mark:
File server :x:

  • it seems the old one wasn’t migrated, I don’t have the “File Server” option in the migrated account provider
  • Creating a new account provider with “Provide file shares and authentication to Windows clients” enabled worked

Dokuwiki :x:

I forgot dokuwiki so I installed it on NS7, removed the account provider on NS7 but it’s not shown in the migration list. Mail was already migrated but the “Start/skip migration” buttons are still shown.

Backup :white_check_mark:

  • Backup to B2 worked, at least I can see the files in the bucket.

Thank you for the complete test, as always your contribute is awesome!

We will try to reproduce, I added a card.
Maybe on the file server @davidep has some ideas.

We didn’t implement it at all. I’m not sure if really does it worth. On ns8, dokuwiki is just an app we used to prototype a web module.

We will check also this one.

1 Like