No bootable device

NethServer Version: nethserver-7.5.1804-x86_64

I was finally able to get a USB drive to boot up Nethserver, but I had to use DD to create it while in Rufus. The USB boots and I’m able to go through the configuration. I have tried both self configuring the drive and using lvm for the configuration. I have made sure that I set the disk as a bootable device.

When the installation finishes and reboot is done I get no bootable device. What did I do wrong?

Hi Michael,

Welcome

Does the computer boot with a traditional BIOS or UEFI ?

If it is UEFI the Rufus tool may have corrupted your install because the USB boots in legacy (BIOS) mode.

Some report etcher does a better job…
(https://www.balena.io/etcher/)

1 Like

I can confirm etcher is a way easier and better performing tool than rufus or unetbootin etc…

the usb drive boots just fine and it goes through the installation. it’s the reboot from the hard disk after the installation is when i get no bootable device. the system i’m building is old enough that it doesn’t know about uefi.

For me Etcher has always done a fantastic job where all others provided me with issues.

also see:

https://www.centos.org/forums/viewtopic.php?f=47&t=68611&hilit=uefi

Do you boot with uefi?

Thanks for the tips. I was able to get a good load after creating the install usb with etcher. now i’m working my way through the config.

2 Likes

Please mark this as solved

@soscc
I could mark it solved, but it is good practice that the Topic Starter (which is you) marks a topic as solved.
I think you want to give @mark_nl credit for mentioning etcher as an option to create a bootable stick.
Click the 3 dots and then click the square with the tick in it so it activates. This way that post is marked as the sollution for your question.

Got it and marked as such. Ty

1 Like