Nextcloud didn't redirect to new database during upgrade

Yes, I will do a snapshot and a mysqldump first. What command will I run to get the database to migrate? In order to get Nextcloud out of the locked state, I ran the manual upgrade from occ so Nextcloud is already 21.0.2, but running on the 5.5 database.

1 Like

we need to investigate why it failed before to going on

this is the resources we gave to innodb, maybe in some cases we need more

/etc/opt/rh/rh-mariadb105/my.cnf.d/mariadb-server.cnf:36:innodb_buffer_pool_size = 128M
/etc/opt/rh/rh-mariadb105/my.cnf.d/mariadb-server.cnf:37:innodb_buffer_pool_instances = 1
/etc/opt/rh/rh-mariadb105/my.cnf.d/mariadb-server.cnf:38:innodb_flush_log_at_trx_commit = 2
/etc/opt/rh/rh-mariadb105/my.cnf.d/mariadb-server.cnf:39:innodb_log_buffer_size = 32M
/etc/opt/rh/rh-mariadb105/my.cnf.d/mariadb-server.cnf:40:innodb_max_dirty_pages_pct = 90

in fact we introduced a lof of steps with tests before to go to the next migration step. We decided to let the nextcloud locked because it forces sysadmin to react and say hey there is something wrong.

We shared with the team and you are the only one with this issue, so the settings should be good for you too. I would like to make a second attempt

  • make a mysqldump of mariadb 55 (verify you have something inside and save it elsewhere)
    mysqldump nextcloud > nextcloud.sql
  • delete the mariadb105 nextcloud database
    /opt/rh/rh-mariadb105/root/bin/mysql --socket="/var/run/rh-mariadb105-mariadb/nextcloud-mysql.sock"
    then drop the database
    drop database nextcloud;
  • add more RAM
  • Do a snapshot of the VM
  • then reinstall the rpm
    yum reinstall nethserver-nextcloud

Thank you, just to be clear, the drop database nextcloud is on the maria105 database correct?

I am out of town tonight, so I’ll have to do this tomorrow evening (US/Pacific) I’ll get back with the results.

Absolutely, destroy the database inside mariadb105, verify it before but it should be empty

Of course keep safe the database of mariadb55

I am doing the migration. I’m noticing that the oc_filecache.ibd file is growing and growing in the new database. That file doesn’t exist in the 5.5 database folder. Currently it is 9.5G and growing.

If finished overnight, but again didn’t transition to the new database. This is the only entry in /var/log/rh-mariadb105/nextcloud.log

2021-07-05 0:38:06 11 [Warning] Aborted connection 11 to db: ‘nextcloud’ user: ‘root’ host: ‘localhost’ (Got an error writing communication packets)

It was still in maintenance mode, so I turned that off and we are running again on the 55 database. I am wondering if I am running out of hard drive space when it it is backing up and adding data to the new database. I have plenty of space, but not on that partition. I will try expanding that and running it again tonight.

1 Like

Yesterday evening, I shut the machine down and booted from Knoppix and rearanged my partitioning and mount points so that the whole /var directory is on my large virtual disk. That gave plenty of room for /var/opt/rh/rh-mariadb105/… to expand. After that, From logs, it looks like the entire process took from 6:45pm to 3:00am to finish, but it did finish, and Nextcloud is now running on the new database and the old one was removed.

Thank you very much for your help.



Thank you very much to give us the chance to help you.

1 Like