Nextcloud 13 - Call for QA!


(Rob Bosch) #61

I will try again this weekend and see if I run into this again…

(Charles) #62

Hello @giacomo, apologies for the late reply.

What’s interesting is the error that occurred was on my test Nethserver. Robb’s fix worked for me on my test server. Since I run my Nethserver’s as a VM (Proxmox) I upgraded my Production Nethserver last weekend after backup and I had no errors on my Prod Nethserver like I did on my test.

I will revert back my test Nethserver to a previous backup and try to recreate the error.

Here are the results of the commands you’ve requested:

[root@mynethtest ~]# account-provider-test dump
   "BindDN" : "ldapservice@MYTESTNETH.CA",
   "LdapURI" : "ldaps://",
   "StartTls" : "",
   "port" : 636,
   "host" : "",
   "isAD" : "1",
   "isLdap" : "",
   "UserDN" : "dc=mytestneth,dc=ca",
   "GroupDN" : "dc=mytestneth,dc=ca",
   "BindPassword" : "xxxxxxxxxxxxxxxxxxx",
   "BaseDN" : "dc=mytestneth,dc=ca",
   "LdapUriDn" : "ldap:///dc%3Dmytestneth%2Cdc%3Dca"


[root@mynethtest ~]# rpm -q nethserver-dc

Thank you.

(Giacomo Sanchietti) #63

There’s no need thank you. If the problem arise again, we will look into it :wink:

(Giacomo Sanchietti) #64

Nextcloud 13.0.2 is out and ready for testing!

(Marc) #65

test case 2 ok (nextcloud 13.0.1 to 13.0.2, with local openldap account provider)

(Alessio Fattorini) #66

@greavette @danb35 we need a few minutes of your time here :smiley:


install on clean vm with local openldap
update on clean vm with local openldap
update on clean vm with remote AD join
all ok

i have External Storage Support enabled (and not configured) in test case with remote AD and after update it is still enable

sorry, i’m not (yet) a nextcloud user so only install/update on test vm

(Giacomo Sanchietti) #68

Thank you! We also it use on production since a week. No problem so far :wink:

I will release it!

(Dr Thomas Quinton) #69

Thank you for your great work.
Just an information. After updating, my nexcloud stuck in service mode, pretending there was a failure. Reinstalling nethserver-nextcloud module solved the Problem?!? All data present and also all additional nextcloud modules (e.g. calander) properly updated.

(Giacomo Sanchietti) #70

It can happen when there are extra app installed.

Instead of reinstall, you should try to re-run the configuration event:

signal-event nethserver-nextcloud-update

(Dr Thomas Quinton) #71

Thank s for the info- it also worked as I discribed above.
Next time…

(Giacomo Sanchietti) #72

If you want, 13.0.4 is ready for testing!

(Alessandro Polidori) #73

For anyone who want to test Nextcloud, new version 13.0.5 is in testing:

(Alessandro Polidori) #74

Released for everyone !

(Alessandro Polidori) #75

New release 13.0.6 !
The testing is open to everyone :wink:
Here it is

I’ve tested the update and clean installation with ldap account provider and all work correctly.

(Markus Neuberger) #76

Fresh install with LDAP worked.

Update install with AD worked.

Update install with LDAP worked, collabora app just worked after the update, I didn’t have to enable it.

Summary: Great Work! :clap:

(Giacomo Sanchietti) #77

Updated a machine with AD, no problem so far, even from clients!

(Mark Verlinde) #78

For what is is worth : port on arm 32bit works to.

(Alessio Fattorini) #79

Thanks so much @mrmarkuz!
Great testing :slight_smile:

(Giacomo Sanchietti) #80

Released again!