Nextcloud 13 - Call for QA!

testing

(Rob Bosch) #61

I will try again this weekend and see if I run into this again…


(Charles) #62

Hello @giacomo, apologies for the late reply.

What’s interesting is the error that occurred was on my test Nethserver. Robb’s fix worked for me on my test server. Since I run my Nethserver’s as a VM (Proxmox) I upgraded my Production Nethserver last weekend after backup and I had no errors on my Prod Nethserver like I did on my test.

I will revert back my test Nethserver to a previous backup and try to recreate the error.

Here are the results of the commands you’ve requested:

[root@mynethtest ~]# account-provider-test dump
{
   "BindDN" : "ldapservice@MYTESTNETH.CA",
   "LdapURI" : "ldaps://mytestneth.ca",
   "StartTls" : "",
   "port" : 636,
   "host" : "mytestneth.ca",
   "isAD" : "1",
   "isLdap" : "",
   "UserDN" : "dc=mytestneth,dc=ca",
   "GroupDN" : "dc=mytestneth,dc=ca",
   "BindPassword" : "xxxxxxxxxxxxxxxxxxx",
   "BaseDN" : "dc=mytestneth,dc=ca",
   "LdapUriDn" : "ldap:///dc%3Dmytestneth%2Cdc%3Dca"

and:

[root@mynethtest ~]# rpm -q nethserver-dc
nethserver-dc-1.4.4-1.ns7.x86_64

Thank you.


(Giacomo Sanchietti) #63

There’s no need thank you. If the problem arise again, we will look into it :wink:


(Giacomo Sanchietti) #64

Nextcloud 13.0.2 is out and ready for testing!


(Marc) #65

test case 2 ok (nextcloud 13.0.1 to 13.0.2, with local openldap account provider)


(Alessio Fattorini) #66

@greavette @danb35 we need a few minutes of your time here :smiley:


#67

tested:
install on clean vm with local openldap
update on clean vm with local openldap
update on clean vm with remote AD join
all ok

i have External Storage Support enabled (and not configured) in test case with remote AD and after update it is still enable

sorry, i’m not (yet) a nextcloud user so only install/update on test vm


(Giacomo Sanchietti) #68

Thank you! We also it use on production since a week. No problem so far :wink:

I will release it!


(Dr Thomas Quinton) #69

Thank you for your great work.
Just an information. After updating, my nexcloud stuck in service mode, pretending there was a failure. Reinstalling nethserver-nextcloud module solved the Problem?!? All data present and also all additional nextcloud modules (e.g. calander) properly updated.


(Giacomo Sanchietti) #70

It can happen when there are extra app installed.

Instead of reinstall, you should try to re-run the configuration event:

signal-event nethserver-nextcloud-update

(Dr Thomas Quinton) #71

Thank s for the info- it also worked as I discribed above.
Next time…


(Giacomo Sanchietti) #72

If you want, 13.0.4 is ready for testing!