Nextcloud 13 - Call for QA!

When it’s ready I guess and it’s tested enough.
Would you mind helping us? So we can shorten this period

1 Like

Upgraded our production server, no problems so far.


NexCloud talk app looks amazing! Very easy and with good performance. They did an amazing job
The WebUI looks very nice and fast

remember to enable the app

and to enable this option

to see the user list


Hi Team,

Here are my results of upgrading Nextcloud on our test server.

Our server specs are:
NethServer release 7.4.1708 (Final)
Kernel Release - 3.10.0-693.17.1.el7.x86_64

I have this Nethserver Test Server spun up since I installed my prod server. Both my Test and Prod run a domain and have Nextcloud installed. I’ve been keeping them both in step with updates whereby I’ll update my test serer first and confirm it’s working and then update my Prod server.

My Prod and Test Nethserver are both running Nextcloud 12.05 (latest version from Nethserver).

I’ve issued the following command on my test server:
yum install nethserver-nextcloud --enablerepo=nethserver-testing

Install was successful. I’ve now tried to login to my test server but my login is not working when I use an ID I’ve created in Nethserver. I can see the login screen and I’ve confirmed I’m using the correct login ID and the correct password. I receive an error that says:

Internal Server Error
The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

Technical details

Remote Address: 10.232.x.x
Request ID: WqFq72Z2m529x8XCEE5rMgAAAA4

I’ve then logged in with the default admin (Nextcloud) account. I can login with this account but everything is extremely slow (both Chrome and Firefox). In the Settings page (used to be called Admin) I can see in my ldap a ‘Configuration Incorrect’ message.

I’ve looked at the logs and I can see the following:

Error core Error while running background job (OC\ServerNotAvailableException): Lost connection to LDAP server.
Fatal webdav Sabre\DAV\Exception\ServiceUnavailable: OC\ServerNotAvailableException: Lost connection to LDAP server.
Error no app in context OC\ServerNotAvailableException: Lost connection to LDAP server.

Anyone else having issues with upgrading to Nextcloud 13 when on a domain?


Updated/Installed from:

  • OpenLDAP + Nextcloud 12.04
  • OpenLDAP + Nextcloud 12.05
  • Local AD + Nextcloud 12.05
  • Clean Install on Local AD

Passed the 4 test cases.
Hit some Nextcloud bugs (groups and shares, #8428, #7499)
The virtual host works (only tested on internal network using a server alias)


Sorry @greavette, but I couldn’t get to reproduce it, I’ve some problem with ad installation on my virtual machine. I’ve tried it binding NS to another ad domain and everythings worked.

Which logs have you seen ?
You can check various logs:

  • nextcloud /var/lib/nethserver/nextcloud/nextcloud.log
  • httpd
  • ldap

Ldap is alive ?
Have you ever customized ldap configuration manually ?

FYI, Nextcloud released Nextcloud 13.0.1


… and it seems to have many improvements !!! :+1:
Hope to have v13 released quickly :wink:


v13.0.0 has been skipped, now 13.0.1 is on pull request


Everything is ready on testing.

If we don’t find any issue, we will release it tomorrow.


Looks great :slight_smile:

Thanks to you all, Nextcloud 13 has been released!


Upgraded from 12.0.5 this morning, seems to work great. Thanks! I’m wondering about this one, though:

I like the idea, but I don’t see where to configure it–is this something that needs to be done at the CLI?

Yes, it can be done from CLI

To customize the Nextcloud web url:

config setprop nextcloud VirtualHost
config setprop nextcloud TrustedDomains
signal-event nethserver-nextcloud-update

If you use let’s encrypt remember to add the domain name to the proper list.


Ah, RTFM strikes again. Sorry, should have looked there.

No problem mate.

Update went without issues.
Removed the old php version (yum remove nethserver-rh-php56-php-fpm rh-php56\*) as I no longer need it.

After a while nextcloud.log showed a few errors (I think it comes from a specific client, but nothing important if does not repeat often):

Fatal	Doctrine\DBAL\Exception\DriverException: An exception occurred while executing 'INSERT INTO `oc_file_locks` (...) SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction
Fatal	Doctrine\DBAL\Exception\UniqueConstraintViolationException: An exception occurred while executing 'INSERT INTO `oc_file_locks` (...) SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry
1 Like

I just installed NC13 from software center after a fully updated NS7.4 server, that has joined my local domain.
I am getting exactly the same error as @greavette:

Internal Server Error
The server was unable to complete your request.
If this happens again, please send the technical details below to the server administrator.
Mre details can be found in the server log.
Technical details
Remote Address:
Request ID: WrOB6WkbhQp@kDTrVnoFZAAAAAE

I managed to log in with the default NC admin user (pw is Nethesis,1234, while I already changed default root pw on the server…)

Then I checked the ldap settings and current config uses ldap and not ldaps
When I change to ldaps with port 636, all works fine…


Thank you @robb, That was my error as well on my test server. Now that I’ve corrected my LDAP settings I can successfully login to my Nextcloud 13 on my test server. Great work!


Thank you @robb and @greavette on finding the solution. By the way this is strange since that part is not changed.

I will try to reproduce and find a fix during next week!