New installation can't access the internet

I installed Nethserver 6.7 latest version, i were not able to connect from my internet browser, I had to add an static IP on my land and then i were able to connect, now that i have connected I cant access the internet, can you help?

you logged in to web interface, how did you connect to the internet, I have installed the latest version 6.7 but cant access the internet is there any guide for connecting the server to the ISP internet?


This depends on your ISP
Have you a standard Internet-Connection using PPPoE or a static IP-Address? Is your Nethservers red interface directly attached to the internet or is there a kind of router between Nethserver and the internet?

Thank you for response, I have a firewall Pfsense that has DHCP service enabled for lan and i tried both DHCP and Static IP on red interface, didnt work for me, i were also not able to connect o lan unless i had to configure my laptop ethernet static IP , any guide?

OK, as far as I understood, you have the following config:

Internet <–> Pfsense <–> Nethserver
And Pfsense is distrubuting IPs via DHCP, right?

What is you current configuration of your interface(s) beside the IP? Is Nethserver getting any IP-Address if you set it to DHCP?
What do you want to do with Nethserver (do you need a RED-Interface)?

yes, my network map looks like this ISP >> PFsense>> Nethserver
PFsense is distributing DHCP, I tried both DHCP and Static on Red Interface to access internet ( Red has but still i cant access the internet,

I want to use Nethserver as Fileserver and Web Filter,

You are also talking about your Laptop.
So I assume your Nethserver has a Red and a Green interface and not just only one interface.

So you have
Internet => pfsense => Nethserver => Laptop
pfsense <=> Nethserver are, right?
Nethserver <=> Laptop are, right?
Your laptop has no connection to, right?
Can you open a console session of Nethserver and check the IPs of nethserver (ifconfig)? Is everything as expected (i.e. green and red are not interchanged)?

Hi, if your setup looks similar to this:

You can read this Install Nethserver as AD with linux and windows clients in the section where the internet interface (RED) is configured.

Also the same is found here for a more quick information, go to point 6:



the configuration should be:
IP PfSense: 192.168.2.X
NS red IP:, the gateway is PfSense 192.168.2.X
NS IP green: 192.168.1.Z

1- Test NS - PfSense
from NS shell (or via ssh client) ping pfsense 192.168.2.X. it works?
If yes, skip to step 2
if no, check the firewall logs on pfsense. If you are not active, enable

2 - Test NS - IP Internet (through PfSense)
From NS try a ping to (google dns). it works?
If yes, skip to step 3
if not, check PfSense log

3 - Test NS - Internet
From NS ping to
if it does not work it could be a DNS problem

I hope I was helpful


@Fahim_Azami it’s nice to see how many people came to help you

1 Like

@Fahim_Azami have you resolved yet? Can you keep us in touch?