Nethserver stopped working

NethServer Version: 7.4.1708
Today Nethserver stopped working.
At 1st Samba stopped working. Users were not able to access shares.
Than the webinterface stopped loading. It hanged at the authentication page.
I tried to access a computer from the LAN remotely with Remote Desktop and the connection hanged.
The SSH access was really slow. It took about 10sec to ask for the password. But I was able to access the shell remotely.
I issued the “reboot” command and the server hanged at the A stop job is running for MariaDB database server than I was not able to access the server remotely.
Someone rebooted the server onsite for me, but the WAN interface didn’t come up.
After the 3rd force reboot I was able to access the server and everything worked.
I uninstalled Nextcloud and MySQL services.

Where should I start to investigate this problem?

You’ll find most entries in /var/log/messages.

If your server is slow again you may use top to find out which process kills your server.

There’s another thread about slow shutdown with mariadb:

Looks like you have already a topic on this issue.
I close this so you can followup on the other one.