Nethserver-rspamd a new module

,

nothing from the dns side… needs rspamd port 80 open?
and it seems rspamd only checks the outgoing emails, not the incoming emails

Nethserver-getmail ???

@mrmarkuz same issue ?

Yes, the getmail workaround for @hucky still relies on spamassassin to filter spam. A nethserver-mail2-getmail package is soon to come.

Seems a good idea, as it’s like amavisd does now. I like to adjust the things in a way that resembles the previous behavior.

2 Likes

Had figured out what the DNS Problem is, if i switch the DNS rules in Suricata at block it blocks every DNS query. never had this before, so sorry for bring it here up.

2 Likes

I have one server with smarthost and getmail so I am looking forward to test nethserver-mail2-getmail…

2 Likes

Just see i got 2 new entrys at rspamd

15.2.2018, 11:10:16 rspamd_proxy 14594 proxy b3e901 got IO timeout with server rspamd.com(88.99.142.95), after 3 retransmits
15.2.2018, 11:05:35 rspamd_proxy 14594 proxy ade00a got IO timeout with server rspamd.com(88.99.142.95), after 3 retransmits

Just an Info :slight_smile:

Did you try the legacy-history and restarted redis and rspamd

yep, do it that way you told me today morning. just for beeing sure, i build the /history_redis.conf cause the file doesent exist.

1 Like

and now the error is still occurring, you can reach the web UI ?

yep, can reach the webui, that was also before no problem.
the error occurs not every time. the last time was what i post here before

1 Like

Ready! https://github.com/NethServer/dev/issues/5394#issuecomment-365926732

You can upgrade getmail from nethserver-testing repo. Follow instructions here:

https://github.com/NethServer/nethserver-mail/blob/6cdd7e625150c8219d012fd4b5bd7b356016b5c0/README.rst#from-pop3-connector-module

Edit: updated manual page

http://docs.nethserver.org/en/latest/mail2.html

2 Likes

thank for monitoring all issues :slight_smile:

1 Like

Installation was succesful, no errors or fails in /var/log/messages. First mails came in via connector and were scanned by rspamd. Looks really good so far!

2 Likes

also at my side rspamd seems to work well. i got one problem, when a spammessage is received it trys to send a mail to spam@spamtrain.nh but it uses the internal mail adress and gives an error cause the intern mailserver has the internal domain xxxxx@xxxx.lan

----- The following addresses had permanent fatal errors -----xxxxxx@xxxxxxxxx.lan+learn_spam@spamtrain.nh

any suggestions?

The internally visible only spamtrain.nh is used to train the bayesian filters since ns6. When an IMAP message is moved to the Junk mail folder (formerly junkmail) it is also sent to that internal domain.

Could you attach any relevant log message from /var/log/maillog?

BTW: on my mail2 server it seems to work correctly

In the Log i found:
Feb 16 05:59:29 sbs sendmail[18819]: w1G4xTMb018819:xxx@xxx.lan+learn_spam@spamtrain.nh… Invalid route address
Feb 16 05:59:29 sbs sendmail[18819]: w1G4xTMb018819: w1G4xTMc018819: DSN: xxx@xxx.lan+learn_spam@spamtrain.nh… Invalid route address
Feb 16 05:59:30 sbs sendmail[18833]: w1G4xUe7018833: xxx@xxx.lan+learn_spam@spamtrain.nh… Invalid route address
Feb 16 05:59:30 sbs sendmail[18833]: w1G4xUe7018833: w1G4xUe8018833: DSN: xxx@xxx.lan+learn_spam@spamtrain.nh… Invalid route address
Feb 16 06:00:32 sbs sendmail[18973]: w1G50WmZ018973: xxx@xxx.lan+learn_spam@spamtrain.nh… Invalid route address
Feb 16 06:00:32 sbs sendmail[18973]: w1G50WmZ018973: w1G50Wma018973: DSN: xxx@xxx.lan+learn_spam@spamtrain.nh… Invalid route address

Well, Postfix should know well that route! Please paste the contents of /etc/postfix/transport

#
# 10relay -- Relay transports
#
xxx.de                     relay:[smtp.1und1.de]:25

#
# 40spam_training
#
spamtrain.nh	   spamtrain

How many local-delivery domains do you have?
How many relay domains?
Is your server FQDN domain configured as local delivery?

one local the internal domain
one relay domain
yep, is configured as local delivery

2 Likes