Nethserver-php-scl for NS7 needs testers

I installed your rpm into a test v7rc3 dc vm with only backup installed, rebooted, selected php 5.6 for Apache and rebooted, didn’t see any issues, installed Nextcloud, added an app, connected with a desktop client and by browser, created a doc with the nextcould app, edited it, shows php5.6 in the nextcloud settings gui, back in the NS gui I added a user, user was added but group add failed, went back and added the user to the group, successful, checked user was in nextcloud user list, success… all good so far, haven’t seen any glitches in the gui pages or in uploading to nextcloud in the browser.

4 Likes

Installed NS v7rc3 … basically, wot he done, except I joined an NS AD domain to get the users - also v7rc3, and being used for real by a small group.

I made a virtual host, and added a phpinfo file and it all worked perfectly with php 5.6, 7 and 7.1.

Now installed a load of NextCloud apps, and more NS Apps. So far no problems.

3 Likes

You made @alep happy, that’s a great news for NextCloud developments

Installed and running on my little server - but have hit a snag.

I have set my default php to php 5.6, and if I put an phpinfo() file in there, I can see the smbclient module loads. However, if I make a vhost, and set it to use php 5.6, the module does not load.

I do not know if there is some limitation to the FPM/FastCGI Server API, or if it is some bug somewhere. FPM/FastCGI does not load htaccess files - but I get the same with a vhost with no htaccess in it as well.

But just had an epiphany - if I set the sites default php to php 5.6, and the vhosts php to default, the vhost uses 5.6, the Server API is Apache 2.0 Handler, and the module is loaded :slight_smile: My problem solved.

But it does mean that if someone wanted to use php > 5.4 - the installed default - but needs a vhost to run 5.4, there is no way to do that.

Cheers,

Don

I don’t get you, what is the relation between apache/php and samba, nethserver-php-scl doesn’t modify the samba service at all.

what is the ‘module’ that you are talking ???

that is the normal behaviour

Indeed if you run php56 for the whole server, php54 is no more available, you must let php54 for apache and in each vhost set another versions

Released :slight_smile:
http://wiki.nethserver.org/doku.php?id=php-scl

1 Like

Good to know, I hope that @quality_team and @Don_Robertson help you test it.

Are we going to make this an official package to be installed from the Software Center?

Hi @fasttech, thank for your interest but i have no plan yet for this.

Then we have no plan for Nextcloud 11…

I believe in the future, @giacomo did a rpm better for this purpose, nethserver-rh-php56-fpm

1 Like

The good news it that @giacomo is working on it and we have a package in testing.

2 Likes

I had dust in my eye when I looked at that on github, so it’s not my fault I didn’t see that… desert dweller and all that.

2 Likes

php72-fpm released for ns7

2 Likes

need inputs for php73-b3, could you test the rpm

yum install http://mirror.de-labrusse.fr/NethDev/nethserver-php-scl/nethserver-php-scl-1.2.4-1.ns7.x86_64.rpm

1 Like

Installs without problems.

Working in /var/www/html and in vhosts:

Tested a website(CMSimple) and a php script, both worked. :clap:

1 Like

teaser…working on another software collection…thank a lot markus I own you a beer at the next fosdem :slight_smile:

1 Like

Looking forward to the new SCL module, the beer and the FOSDEM! :sunglasses:

2 Likes

https://wiki.nethserver.org/doku.php?id=python-scl

2 Likes

Amazing job man. Kudos!