Nethserver-nextcloud - can't see any files when connecting via phone app

NethServer Version: your_version

$ yum info nethserver-base

Installed Packages
Name : nethserver-base
Arch : noarch
Version : 3.6.1
Release : 1.ns7
Size : 673 k
Repo : installed
From repo : nethserver-base
Summary : NethServer basic configuration
URL : http://github.com/NethServer/nethserver-base
License : GPL
Description : The nethserver-base package provides the fundamental
: infrastructure for the configuration management of NethServer,
: derived from SME Server event and template system.

Module: your_module

$ yum info nethserver-nextcloud

Installed Packages
Name : nethserver-nextcloud
Arch : noarch
Version : 1.3.0
Release : 1.ns7
Size : 45 k
Repo : installed
From repo : nethserver-base
Summary : NethServer Nextcloud configuration
URL : http://github.com/NethServer/nethserver-nextcloud
License : GPL
Description : NethServer Nextcloud files and configuration.

As I am writing this, I am realizing maybe some installed packages could have an impact on this,

Here’s all the packages from the nethserver repo:

$ yum list installed | grep nethserver-

c-icap.x86_64 0.5.2-1.ns7 @nethserver-base
c-icap-libs.x86_64 0.5.2-1.ns7 @nethserver-base
cockpit.x86_64 183-1.el7 @nethserver-base
cockpit-bridge.x86_64 183-1.el7 @nethserver-base
cockpit-packagekit.noarch 183-1.el7 @nethserver-base
cockpit-storaged.noarch 183-1.el7 @nethserver-base
cockpit-system.noarch 183-1.el7 @nethserver-base
cockpit-ws.x86_64 183-1.el7 @nethserver-base
evebox.x86_64 0.9.0-1 @nethserver-base
iaxmodem.x86_64 1.2.0-1.ns7 @nethserver-base
kmod-xt_ndpi.x86_64 2.4.0-1.ns7 @nethserver-base
lightsquid.noarch 1.8-18.el7.lux @nethserver-base
lightsquid-apache.noarch 1.8-18.el7.lux @nethserver-base
nethserver-antivirus.noarch 1.2.1-1.ns7 @nethserver-base
nethserver-avahi.noarch 1.1.0-1.ns7 @nethserver-base
nethserver-backup-config.noarch 2.2.2-1.ns7 @nethserver-base
nethserver-backup-data.noarch 1.4.3-1.ns7 @nethserver-base
nethserver-base.noarch 3.6.1-1.ns7 @nethserver-base
nethserver-c-icap.noarch 1.1.0-1.ns7 @nethserver-base
nethserver-cockpit.noarch 0.1.1-1.ns7 @nethserver-base
nethserver-collectd.noarch 3.0.7-1.ns7 @nethserver-base
nethserver-cups.noarch 1.2.1-1.ns7 @nethserver-base
nethserver-diagtools.noarch 1.0.3-1.ns7 @nethserver-base
nethserver-dnsmasq.noarch 1.6.7-1.ns7 @nethserver-base
nethserver-duc.noarch 1.4.5-1.ns7 @nethserver-base
nethserver-evebox.noarch 1.1.0-1.ns7 @nethserver-base
nethserver-firewall-base.noarch 3.5.0-1.ns7 @nethserver-base
nethserver-firewall-base-ui.noarch 3.5.0-1.ns7 @nethserver-base
nethserver-hosts.noarch 1.2.2-1.ns7 @nethserver
nethserver-httpd.noarch 3.2.7-1.ns7 @nethserver-base
nethserver-httpd-admin.noarch 2.3.4-1.ns7 @nethserver-base
nethserver-hylafax.noarch 1.3.5-1.ns7 @nethserver-base
nethserver-iaxmodem.noarch 1.2.5-1.ns7 @nethserver-base
nethserver-ipsec-tunnels.noarch 1.1.4-1.ns7 @nethserver-base
nethserver-lang-en.noarch 1.2.17-1.ns7 @nethserver-base
nethserver-letsencrypt.noarch 1.1.6-1.ns7 @nethserver
nethserver-lib.noarch 2.2.9-1.ns7 @nethserver-base
nethserver-lightsquid.noarch 1.1.2-1.ns7 @nethserver-base
nethserver-lsm.noarch 1.2.3-1.ns7 @nethserver
nethserver-mail-smarthost.noarch 2.4.2-1.ns7 @nethserver-base
nethserver-mysql.noarch 1.1.4-1.ns7 @nethserver-base
nethserver-ndpi.noarch 1.2.0-1.ns7 @nethserver-base
nethserver-nethforge-release.noarch 7-3.ns7 @nethserver-base
nethserver-nextcloud.noarch 1.3.0-1.ns7 @nethserver-base
nethserver-ntopng.noarch 2.1.1-1.ns7 @nethserver-base
nethserver-ntp.noarch 1.1.3-1.ns7 @nethserver
nethserver-openssh.noarch 1.2.2-1.ns7 @nethserver
nethserver-openvpn.noarch 1.7.0-1.ns7 @nethserver-base
nethserver-phonehome.noarch 1.3.0-1.ns7 @nethserver
nethserver-php.noarch 1.2.0-1.ns7 @nethserver
nethserver-pulledpork.noarch 2.1.3-1.ns7 @nethserver-base
nethserver-release.noarch 7-11.ns7 @nethserver-base
nethserver-rh-php71-php-fpm.noarch 1.0.0-1.ns7 @nethserver-base
nethserver-samba.noarch 4.2.0-1.ns7 @nethserver-base
nethserver-smartd.noarch 1.1.0-1.ns7 @nethserver
nethserver-squid.noarch 1.7.3-1.ns7 @nethserver-base
nethserver-squidclamav.noarch 3.0.0-1.ns7 @nethserver-base
nethserver-squidguard.noarch 1.8.0-1.ns7 @nethserver-base
nethserver-sssd.noarch 1.4.7-1.ns7 @nethserver-base
nethserver-subscription.noarch 3.2.1-1.ns7 @nethserver-base
nethserver-subscription-ui.noarch 3.2.1-1.ns7 @nethserver-base
nethserver-suricata.noarch 1.1.1-1.ns7 @nethserver-base
nethserver-yum.noarch 1.4.1-1.ns7 @nethserver
nextcloud.noarch 14.0.4-1.el7 @nethserver-base
ntopng.x86_64 3.3.180109-3804 @nethserver-base
ntopng-data.noarch 3.3.180109-3804 @nethserver-base
pfring.x86_64 7.1.0-1681 @nethserver-base
restic.x86_64 0.9.3-1.ns7 @nethserver-base
squid.x86_64 7:3.5.20-999.ns7 @nethserver-base
squid-migration-script.x86_64 7:3.5.20-999.ns7 @nethserver-base
squidclamav.x86_64 6.16-1.ns7 @nethserver-base
ufdbGuard.x86_64 1.33.7-CentOS7 @nethserver-base

Can’t see any files on either Admin or LDAP (AD) user on fresh installation of Nethserver-nextcloud when connecting with Android app. Web viewing appears to work fine on LAN.

I am on the same LAN while testing. SSL cert is self-signed default. I haven’t messed with any of the firewall/intrusion prevention features yet, Nextcloud was my first thing I tried to configure after basic hostname/dns configuration and joining the VM to AD. Sonicwall is turned off (my LAN is behind another firewall).

Has anyone had any issues seeing files from their phone?

Thanks!

Edit: This problem appears to have corrected itself over time - I wonder if it has something to do with local caching on the app?

  1. couldn’t see any files
  2. could see files, but couldn’t open them
  3. could then see files and open them on wifi but not internet
  4. now can see files and open them on wifi and internet

In any event, it appears to be working now. Thanks for the high-quality, easy to use Nextcloud framework! You’ve sure saved me a lot of time and hassle.

Good job. You should mark this thread as solved !