Nethserver can't restart after updates

Good morning I started nethserver updates last night, an operation I had not done for several months, but after half an hour I lost the connection with nethserver server manager. This morning mail did not work, clients do not connect to the internet and I can’t connect to the server manager. I can’t log in to the server manager. If I restart the server I can login to the server manager many minutes then I lose the connection. "Sec_error_ocsp_try_server_later.
I can see only the samba folder.
How can i do?
Thanks Enrico

Please try to login via a ssh-shell (putty for example) and have a look at the messages log


1 Like

It should be a time problem.

Take a loot at:

I can not connect with putty. I can insert the user name and password, it seems to log in correctly, but i can’t se the command line, but when I insert a command like reboot or help I am asked to re-log in. But now i can log in the server manager and i can see /var/log/messages The only problem that i can see is "dnsmasq [1836]:maximun number of concurrent DNS queries reached (max: 150). When the system is rebooted, the server unloads mail and distributes it to the clients but then stops after a few minutes.

I think the dnsmasq error is a result of your error. It looks like some services try to reach dns to often at the same time.
@giacomo Do you have an idea how to find out which service is it?

I don’t think dnsmasq error is relevant right now.

@enrico.s you need to do one test and time and check the result on your machine:

  1. Connect with the monitor, try to login, and see what happens
  2. Check the network connectivity, try some ping and ssh to other machine from the server iteslf
  3. You absolutely need to find the moment when the server stops working and see the relevant logs at that time

Everything sounds to me like a network problem, I’d bet on a conflicting IP :slight_smile:

1 Like

Thanks, Giacomo

I can’t connect a monitor, it’s a virtual machine on esxi, if i see the consol on vshpere i can login with admin user but when i insert a command line the server log out me.
I also think it’s a dns problem. Microsoft Edge give me the error “il nome DNS non esiste” error “INET_E_RESOURCE_NOT_FOUND”. The client Outlook can’t connect to the server. Iphone client (Exchange) Always ask me the password and tell me it’s wrong.

Now i see that for some second the to bar become red with this error “account provider error 82”. And under the left black bar “[512] No Response From Server See system log details nethserver”

Solved, the problemit was not the update of nethserver, but the non-functioning concurrently of the telecom dns that I used
Thanks Enrico

Can you mark it as solved please.

So, if the external DNS’s where Nethserver points are non functioning, Nethserver crashes?
Isn’t a good thing…

Uhm which version of NethServer are you running? Is it updated to last version?

I think saitobenkei is right.

Can you tell us your configuration please, we have to find out why this could happen.

Nethserver release 7.4.1708 updated from 7.3. The server is installed on a virtual machine hosted on a ESXI server that is internal to the network .

If your ISP DNS is not reliable you might want to consider to change to free privacy friendly DNS services:

Any other known reliable DNS providers?

What is about the DHCP, Gateway, and DNS configuration?

I tried rebooting a test VM with wrong DNS settings now and could reach the admin web UI and connect via SSH. Some services may rely on working DNS and maybe there are some timeouts, but it should work generally.

I also pick some servers from different free dns providers mentioned in your link and this is working fine for me because even if one provider fails completely another one will likely work.

Another thread about “good” DNS providers: