Nethserver as domain controller

not NS related, but could help:

some entry in windows’ registry are needed


It is a bug and it must be reported. You can not have roaming profile without the {V3,V4,V5} folders.


Hi all,
and of course: you are very, very kind. Thanks.
Now I tried again with a Win 7 client and I confirm that it works correctly.
In NS wiki I read that “NethServer emulates a Windows 2000/NT domain controller”. In another forum people noticed that Win 10 doesn’t support Windows 2000 domain controller.
Perhaps the problem is NS doesn’t support Win 10 clients for this reason?

W10 is supported as long as you “patch” the windows’ registry

1 Like

when a new user is created, all the needed subdir in his home dir must be created…

thans to M$ that keep thing easy :slight_smile:

Following the workaround proposed by Bogdan after I created userfolder.V5 empty folder starting from userfolder.V2 first for the admin and then for one normal user the join to the domain and the logon of Admin and normal user go ok.
Perhaps could updating Samba to the last version solve this problem?
However, till new solutions I think I will create manually .V5 folders for the W10 clients.

This is a NS’ issue, not a samba one

Ok Stefano.

I agree with @zamboni and @stephdl: we need to file a bug/enhancement to fix this.

So the proposed solution is creating the empty .Vn folders? The following code is responsible for that:

Does anybody want to take care of

This could be a good workbench to learn the development process! (@alefattorini)

1 Like

Totally agree, just opened a new topic about that

I’ve created a fork on Git. It should now create all the windows profile folders required (also added for the delete account script). I did not have the time to test this but is should work
It has to be tested though :smiley:.
Please provide feedback so we can merge this into NS.

Best regards

1 Like

A post was split to a new topic: Roaming profiles per user settings

while @Ctek is doing the hard work, i have opened the issue :slight_smile:


Hi guys, I’ve fixed this and built an rpm.
But sadly I can’t test it because I’m allergic to Windows…Package is in testing repo and issue needs QA :wink:

1 Like

I’m now understand the avatar :laughing: :laughing: :laughing:


@dz00te is your turn :slight_smile: easy QA to make for start smoothly with testing

Can anyone test this issue?
I can check the server configuration but I don’t have any Windows machine to test the roaming profile.

mee too, installed on my proxmox 3 windows+update (7,8.1,10)… it has been a long battle :smile:
but it’s done… waiting info to set as verified

Done! :smiley:

tnx, set as verified (finally) :grimacing:

1 Like