Need help with installing Active Directory

Please could you make screenshots in english or you could have helps only in your mother tongue

could you add also the the network and the ip address of your server, if you use virtualization you should check the documentation, for example virtualbox need the promiscuity mode allowed

I changed some settings and disabled DHCP. Now it failed on this:
Copied stuff:

echo ‘{“errors”:{“IpAddress”:{“hasError”:false,“message”:""},“Workgroup”:{“hasError”:false,“message”:""},“Realm”:{“hasError”:false,“message”:""}},“isChecking”:false,“Realm”:“ad.emyu-server.local”,“Workgroup”:“EMYU-SERVER”,“IpAddress”:“”,“action”:“local-ad”,“isLoading”:true}’ | /usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-accounts-provider/update | jq

Failed command:

this is not really interesting, content of /var/log/messages is far better

¿Have You put the fixed IP address for green interface?

Yes, I did.

This is the latest content.

like you can see you cannot download and install by yum nethserver-dc, what is the output of yum update in the terminal

your server does not have network connectivity,


adjust GateWay and DNS to fit your network.

1 Like

here we are :smiley:

It‘s stuck on nethserver-dc-save.

You don’t have network connectivity, try first to stablish a internet connection.

It could be that yum is doing something because it shows YUM something like 0,5 seconds. I will wait a few minutes.

It just finished. Thank you for your help :slight_smile:

same command as above


Welcome to the forum @theemuly,
most people here don’t speak German, so please set your language to English and do a new screenshot.
I’m not one of the people who don’t speak German, so I try to help you, because I can read the error message.
You have to create a green network with a static IP, for example

The IP for Active Directory has to be at the same subnet as the server:

For example you can choose the IP you tried with.
But be aware that they are not at the DHCP-Range of your network.

1 Like

It works :slight_smile:

1 Like

Hi @theemuly,
Could you please choose the answer which helped you and mark it as solved.

1 Like