Moodle 503 service temporarily unavailable


(Rob Bosch) #21

Hi @mrmarkuz
I am dusting off the moodle module again. I notice that with a vanilla NethServer 7.5, updated to the latest patchlevel, php7.1 is still not set by default for Moodle.
As you suggested in a previous reply:

yum install nethserver-rh-php71-php-fpm
systemctl restart httpd

resolves the problem. So it seems the php71-php-fpm package is still not added or activated by the nethserver-moodle rpm.

Could you look into this?


(Markus Neuberger) #22

Thanks for testing, it should be fixed now. I uploaded a new rpm. You may update with

yum update nethserver-moodle


(Rob Bosch) #23

Thanks a lot @mrmarkuz Confirmed that the issue is fixed.


(Markus Neuberger) #24

You may try the update on a test machine:

yum install https://mrmarkuz.goip.de/mirror/devtest/nethserver-moodle-0.1.2-1.9.g3c22882.ns7.noarch.rpm


So, what are you working on? 10 Dec 2018
(Rob Bosch) #25

Thanks a lot @mrmarkuz
Installing a new NS VM as we spreak. Will comment back as soon as I know more.
I will be doing a fresh install and an update from Moodle3.5


(Markus Neuberger) #26

Thanks for testing!
In this module version the cli php installer/updater is used to fully setup moodle and an admin account with default password “Nethesis,1234” instead of using the web installer. Additionaly I added the moodle cron job.

https://docs.moodle.org/36/en/Installing_Moodle_using_command_line
https://docs.moodle.org/36/en/Cron


(Rob Bosch) #27

Does that mean you also use a NS virtual host to install it in?


(Markus Neuberger) #28

Sorry, what do you mean with NS virtual host? The one you can setup via web UI? In this case no.
Nothing has changed in httpd configuration. You still can reach moodle via https://nethserver/moodle.


(Rob Bosch) #29

Fresh install works as expected.

I received an error on the webinterface after updating from Moodle 3.5… Could have something to do with the autoconfig of moodle in the new package.


(Markus Neuberger) #30

Do you use moodle plugins/extensions?

I didn’t get that one when testing…I only found this thread:

https://moodle.org/mod/forum/discuss.php?d=368968

What you could try:

  • Maybe a permission problem:
    chown -R apache:apache /usr/share/moodle
  • Try another signal-event nethserver-moodle-update
  • Check logfiles (/var/log/messages, /var/log/httpd/*)