Monitoring agent on arm

I took a quick look at the zabbix website to see WHAT it monitored. For all I knew, it monitored your office A/C system…

Shows how much attention I pay to managing networks!

  1. Fast network card for data acquisition. 1GB ethernet is not hard to get.

  2. Good I/O for the DB. Native sata valuable, but you could put the DB on USB 3.0 drive. So look for either.

  3. At least duo core for data store and data reporting. Quad would be better.

  4. Is the graphic rendering done in the agent or the server? If the later, then quad core is probably mandatory.

A lot of armv7 SOC meet this list, so it would not be hard to put together.

BTW, thanks Mark for the sunxi pointers. Turns out the R40 Allwinner chip that is in the BananaPi M4-Ultra will not have sata support until the 4.20 kernel. So I am either back to looking for quad board alternatives or waiting until?

But I don’t have anything here worth monitoring, so I will focus on what I do need and can help with.

I am going to provide a zabbix-mysql noarch package where we could start from.

Another thing is that some repackaging of the zabbix packages is needed. IIRC epel only provides zabbix 2.2 and from zabbix repo you can actually get 4.0 LTS.


For arm it is updated to 3.0.22-2, but we have version 4.0.0-2 (kind of in the hope the LTS 4.0 package will land soon) epel=pass1 is needed one dependency, I will include it in our mirror soon.

1 Like

Here is a first test module for the epel zabbix version 3 using mysql:


Did you already port the packages? If yes then I noticed too late.

1 Like

Tested the postgres version now on a raspberry and it works. Great! :sunglasses:
Did you port the zabbix packages? Is it possible to make them noarch?
I am going to provide another package for zabbix 4 and mysql. Then we have all possibilities (epel, zabbix, postgres, mysql)
Epel and zabbix versions slightly differ in provided db files and config file locations.

1 Like

Yes i did rebuilt zabbix 4.0, just a mater of rebuildning the source package the provide.

Funny think is I just removed it from the arm testing repository and while writing this your nethserver-zabbix-mysql package installed oke!

so now we have nethserver-zabbix-mysql in testing and no zabbix package it self. But if you favor 4.0 it’s easily put back. :grinning:

EDIT: zabbix 4.0 packages are in testing again. I saw your package requires specific version; so no installation conflict are to be expected.

1 Like

We may keep both, the epel packages are named zabbix30-* whereas the zabbix packages only have zabbix-*. I already added it to conflicts definition in the spec file so it should not be possible to install both.

I’d change the name of the epel package to nethserver-zabbix30-mysql and make a new nethserver-zabbix-mysql. What do you think?

I think the newer zabbix packages are preferred in general so if it’s too much effort to keep both versions we may drop the epel one.

1 Like

Done: zabbix 4.0 packages are in testing again


[OT mode on]
I would like to write much more, thank everyone for their contributions and passion, try to explain why even if I do not have time to be active lately, even reading just makes me feel an active part of the community … to be short: thanks to the whole nethserver community :+1:
[OT mode off]

i agree

just installed… i’ve seen some warnings in logs but zabbix4 seems to work.
@mrmarkuz @mark_nl great job!:raised_hands:
I hope to have some free time tomorrow to make other tests on hc1 and rpi3 and send the logs


I reworked the zabbix module to use the new Zabbix 4.0 packages and mysql instead of postgres, it works on my raspberry in first tests. The only package needed from epel-pass1 is fping.

yum install --enablerepo=nethserver-testing,epel-pass1


Nice! will include fping in the ns-epel mirror.

1 Like

fping is included in the ns-epel mirror, epel-pass1 may be omitted from the install command.
(did not test this!)

1 Like

During the zabbix rebuild for aarch64 I saw a zabbix update to 4.0.1-1;
Can this be pushed to armhp too?

1 Like

I’ll try and report…

If you wish, I can push them…
If it’s not oke we remove them again… it’s a devel repo!

1 Like

ok, usually they should work. Never experienced a problem with zabbix packages.

1 Like


Tomorrow i’ll try them too! Thanx

1 Like

Thanks for providing the new packages, I updated and it worked as expected. :sunny:

1 Like

Installed it on aarch64 and it works. :grinning:

To be accuracte it did need a manual stop and start of the zabbix-server.service.
This is most likely my fault by over doing it, just to many services are installed / running.

.. systemd[1]: Starting Zabbix Server...
.. systemd[1]: zabbix-server.service: Supervising process 3659 which is not our child. We'll most likely not notice when it exits.
.. systemd[1]: Started Zabbix Server.
.. systemd[1]: zabbix-server.service: main process exited, code=exited, status=1/FAILURE
.. kill[3663]: Usage:
.. kill[3663]: kill [options] <pid|name> [...]
.. kill[3663]: Options:
.. systemd[1]: zabbix-server.service: control process exited, code=exited status=1
.. kill[3663]: -a, --all              do not restrict the name-to-pid conversion to processes
.. kill[3663]: with the same uid as the present process
.. kill[3663]: -s, --signal <sig>     send specified signal
.. kill[3663]: -q, --queue <sig>      use sigqueue(2) rather than kill(2)
.. kill[3663]: -p, --pid              print pids without signaling them
.. kill[3663]: -l, --list [=<signal>] list signal names, or convert one to a name
.. kill[3663]: -L, --table            list signal names and numbers
.. kill[3663]: -h, --help     display this help and exit
.. kill[3663]: -V, --version  output version information and exit
.. kill[3663]: For more details see kill(1).
.. systemd[1]: Unit zabbix-server.service entered failed state.
.. systemd[1]: zabbix-server.service failed.
.. systemd[1]: zabbix-server.service holdoff time over, scheduling restart.

I had the same log entries but services were restarted during the update so it worked without manual restart.