MAC validation (IP/MAC binding) not work without RED interface

NethServer Version: 7.3.1611 (Final) + last update
Module: firewall

i use only green interface.
I use DHCP and IP reservation it’s work fine!
if i set checkbox MAC validation (IP/MAC binding) in Firewall it’s see me error
sorry my English…

MAC validation has been designed only for firewalls, thus you need a green and a red interface.

If you want to modify the behavior, you could create a template-custom for this fragment: /etc/e-smith/templates/etc/shorewall/interfaces/20nics.

1 Like

I do not know how…

You can find all information about template custom here:

WARNING: It’s only a idea: I don’t know if it works or not

Create a template custom:

mkdir -p /etc/e-smith/templates-custom/etc/shorewall/interfaces

cd /etc/e-smith/templates-custom/etc/shorewall/interfaces

cp /etc/e-smith/templates/etc/shorewall/interfaces/20nics .

Modify 20nics under /etc/e-smith/templates-custom/etc/shorewall/interfaces

vi 20nics

Row 21:


$OUT .= "net\t".$i->key."\tdhcp,nosmurfs,optional";


$OUT .= "net\t".$i->key."\tdhcp,nosmurfs,optional".$mac_option;

save the file, then:

expand-template /etc/shorewall/interfaces
signal-event firewall-adjust

Put the check again on the option where you have error (I don’t find that option in my dashboard…) then make a test.

If this doesn’t work reverse the modify:

cd  /etc/e-smith/templates-custom/etc/shorewall/interfaces
rm 20nics
expand-template /etc/shorewall/interfaces
signal-event firewall-adjust