Lock to "current release" enabled by default from 7.5

We can’t cover all the needs but we can try to give people a choice

  • being conservative (update just my release) stable mode
  • being brave (update all) edge mode

For me, if we explain that well it’s a good balance.
As we know, making a complex interface with a lot of choices confuses people.


No no! The two options are two ways of updating the system in the same release

I want to add it as a yellow banner with a button that appears when a new minor is available: what do you think?

1 Like

Although I usually like being brave, when it comes to my NethServer installation at home - I have to treat it as Production class which means I do need to be a little conservative with it.

1 Like

Ok let’s give a name to the available choices. A name is important to understand what we’re talking about and for documentation references. I don’t like “brave”, I’d prefer “expert” because one must understand what is being updated. It gets the best of security fixes and updates. “Conservative” still needs some expertise but is less error-prone.

So this is my proposal

  • Conservative
  • Expert

I’ll send a screenshot soon

About stable/edge mode: both policies are stable in the same way IMO. It depends on how they are used.

Make that all repositories that are not able to differentiate between minor / point updates. The goal is to not break a running server because of upstream point updates.

But if you are expert but can’t differentiate between updates (choose what to update and what not), there is not much ‘expert’ about updating. Then it’s more like rolling dice.
Wouldn’t it be feasible to have an option to allow and disallow updates on a per-package basis?


We discussed that #feature in the past and I agree with @giacomo here Cherry pick updates in Software Center :

To be able to cherry pick updates, you need a deep understanding of rpm packages interactions and system libraries.

That proposal was not able block dependencies, so I abandoned it because it solves the problem partially.

What changes with “software update policy” is the set of repositories enabled during updates.

I’d name it “expert” because it requires some expertise about what’s happening, as we learned during the past week, when some people just pressed “update” even if a “new distribution is available” warning was displayed. The “conservative” policy would make that kind of mistake impossible.

…but please suggest other names! I’m sure my proposal can be improved!

Both policies wouldn’t save us from a badlock-like regression coming from upstream. If that happens again in the future, the only thing that can help is a careful review (and backup) before updating.

1 Like

Come on guys, if you’re able to choose what updates to select, you’re enough expert do it by from the command line line. It’s just a couple of commands to learn! :wink:

1 Like

“Return to Innocence” :wink:

1 Like

Guinea pig? :yum:

1 Like

Yes of course, but I think at softwarecenter it’s a little bit more clear.

We should choice terms that are clear for the man in the street.
I would suggest:

  • Conservative (more stable, less updated)
  • Bleeding Edge (upstream compliant, less stable)



…living on the Bleeding edge:


I prefer “solid”, “stable” or “(well) balanced” instead of “conservative”.

“Bleeding edge” is as stable as “conservative”: it only needs more care and skills. It is more balanced than conservative IMO, because it offers the latest version of every package.

If it’s stable, why ‘alpha’ or ‘beta’ where choosen as definition into topic name?
Or why there are bugs blocking the upgrade process?
Even “bleeding edge” definition do not exactly seem to mean “Rock solid”…

Don’t call it stable

My intention was to replace conservative as it has a touch of old-fashioned. Seems hard to find the right wording…


Yes too hard! Why not use the same naming scheme of TLS policy page? It’s just a number :slight_smile:

  • Policy 1
  • Policy 2

If you prefer

  • Red pill
  • Blue pill

As alternative we can change the way we choose the boolean release lock state: checkbox instead of radio button …so we need to decide just ONE name :blush:

1 Like

If one is going to use “bleeding edge”, then I feel that “conservative” is a bit more appropriate than “stable”. “solid” or “(well) balanced” just doesn’t seem to fit well and could be open to misunderstanding.

you’re missing some points, I’m afraid

It seems they are misleading too… I’m a devellopper: let’s name them after what they do!

  • Unlocked
  • Locked