Leantime install

NS7 has dark mode, i am sure NS8 will too. considering its mostly admin dashboard, and most geek dashboards are dark,

no shame in making a geek feel cool :slight_smile: - more semi dark mode coming from the vfx industry where dark themes are the default…

related? tried without forcing ssl but no difference…

[mpm_prefork:notice] [pid 1241] AH00170: caught SIGWINCH, shutting down gracefully
[Tue Oct 25 23:36:54.208649 2022] [suexec:notice] [pid 20101] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Oct 25 23:36:54.211225 2022] [ssl:warn] [pid 20101] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Tue Oct 25 23:36:54.233295 2022] [lbmethod_heartbeat:notice] [pid 20101] AH02282: No slotmem from mod_heartmonitor
[Tue Oct 25 23:36:54.235449 2022] [ssl:warn] [pid 20101] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)

lsof -i -P -n
mysqld 2156 mysql 14u IPv4 40725 0t0 TCP *:3306 (LISTEN)

should there not also be an entry for sql103 port 3313? i added one manually in firewall/ports. but didnt help

It’s IPv6:

[root@server2 ~]# lsof -i -P -n | grep 3313
mysqld    29558                    mysql   69u  IPv6 10704984      0t0  TCP *:3313 (LISTEN)

Is IPv6 disabled? (1 = disabled)

sysctl -a 2>/dev/null | grep disable_ipv6


net.ipv6.conf.all.disable_ipv6 = 0
net.ipv6.conf.aqua0.disable_ipv6 = 0
net.ipv6.conf.br-899e5d1b78e8.disable_ipv6 = 0
net.ipv6.conf.default.disable_ipv6 = 0
net.ipv6.conf.docker0.disable_ipv6 = 0
net.ipv6.conf.enp0s31f6.disable_ipv6 = 0
net.ipv6.conf.enp5s0.disable_ipv6 = 0
net.ipv6.conf.lo.disable_ipv6 = 0
net.ipv6.conf.veth4a2c6bb.disable_ipv6 = 0
net.ipv6.conf.veth924f2aa.disable_ipv6 = 0

But it did work earlier…strange.

Is the service active?

systemctl status rh-mariadb103-mariadb -l

yeah… its running :expressionless: think i saw a flash of a login screen a couple of days ago. but no… leant. never ran before…

systemctl status rh-mariadb103-mariadb -l
● rh-mariadb103-mariadb.service - MariaDB 10.3 database server
   Loaded: loaded (/etc/systemd/system/rh-mariadb103-mariadb.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2022-10-28 00:13:05 CEST; 35min ago
     Docs: man:mysqld(8)
  Process: 8023 ExecStartPost=/usr/bin/scl enable $RH_MARIADB103_SCLS_ENABLED -- /opt/rh/rh-mariadb103/root/usr/libexec/mysql-check-upgrade (code=exited, status=0/SUCCESS)
  Process: 7945 ExecStartPre=/usr/bin/scl enable $RH_MARIADB103_SCLS_ENABLED -- /opt/rh/rh-mariadb103/root/usr/libexec/mysql-prepare-db-dir %n (code=exited, status=0/SUCCESS)
  Process: 7915 ExecStartPre=/usr/bin/scl enable $RH_MARIADB103_SCLS_ENABLED -- /opt/rh/rh-mariadb103/root/usr/libexec/mysql-check-socket (code=exited, status=0/SUCCESS)
  Process: 7908 ExecStartPre=/usr/bin/scl enable $RH_MARIADB103_SCLS_ENABLED -- /usr/bin/scl_enabled rh-mariadb103 (code=exited, status=0/SUCCESS)
 Main PID: 7988 (mysqld)
   Status: "Taking your SQL requests now..."
    Tasks: 30
   Memory: 77.6M
   CGroup: /system.slice/rh-mariadb103-mariadb.service
           └─7988 /opt/rh/rh-mariadb103/root/usr/libexec/mysqld --basedir=/opt/rh/rh-mariadb103/root/usr

Oct 28 00:13:05 tank.domain.com systemd[1]: Starting MariaDB 10.3 database server...
Oct 28 00:13:05 tank.domain.com scl[7945]: Database MariaDB is probably initialized in /var/opt/rh/rh-mariadb103/lib/mysql already, nothing is done.
Oct 28 00:13:05 tank.domain.com scl[7945]: If this is not the case, make sure the /var/opt/rh/rh-mariadb103/lib/mysql is empty before running mysql-prepare-db-dir.
Oct 28 00:13:05 tank.domain.com mysqld-scl-helper[7988]: 2022-10-28  0:13:05 0 [Note] /opt/rh/rh-mariadb103/root/usr/libexec/mysqld (mysqld 10.3.35-MariaDB) starting as process 7988 ...
Oct 28 00:13:05 tank.domain.com mysqld-scl-helper[7988]: 2022-10-28  0:13:05 0 [Warning] Could not increase number of max_open_files to more than 1024 (request: 32186)
Oct 28 00:13:05 tank.domain.com mysqld-scl-helper[7988]: 2022-10-28  0:13:05 0 [Warning] Changed limits: max_open_files: 1024  max_connections: 151 (was 151)  table_cache: 421 (was 2000)
Oct 28 00:13:05 tank.domain.com systemd[1]: Started MariaDB 10.3 database server.

ill try and sum it up and see if i get a reply from the leant. guys…

1 Like

thats the reply i got from the leantime guys… any ideas?

When understanding that “localhost” and “” have a different function, it should also be clear that rights on the server using @localhost or @ are different. You should not see localhost as a domain that gets resolved to

I retested it and

public $dbHost=''; //Database host

worked instead of defining the port like

public $dbPort='3313';

1 Like

thanks for checking. i find it pretty odd that you can run it out of the box… i am still getting the same behavior… it actually prints a connection error in the maria103 log. why would it print localhost even if i have 127 in the config?

2022-11-14 10:59:30 0 [Note] InnoDB: Using Linux native AIO
2022-11-14 10:59:30 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2022-11-14 10:59:30 0 [Note] InnoDB: Uses event mutexes
2022-11-14 10:59:30 0 [Note] InnoDB: Compressed tables use zlib 1.2.7
2022-11-14 10:59:30 0 [Note] InnoDB: Number of pools: 1
2022-11-14 10:59:30 0 [Note] InnoDB: Using SSE2 crc32 instructions
2022-11-14 10:59:30 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2022-11-14 10:59:30 0 [Note] InnoDB: Completed initialization of buffer pool
2022-11-14 10:59:30 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2022-11-14 10:59:30 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
2022-11-14 10:59:30 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2022-11-14 10:59:30 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2022-11-14 10:59:30 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2022-11-14 10:59:30 0 [Note] InnoDB: Waiting for purge to start
2022-11-14 10:59:30 0 [Note] InnoDB: 10.3.35 started; log sequence number 1625639; transaction id 20
2022-11-14 10:59:30 0 [Note] InnoDB: Loading buffer pool(s) from /var/opt/rh/rh-mariadb103/lib/mysql/ib_buffer_pool
2022-11-14 10:59:30 0 [Note] InnoDB: Buffer pool(s) load completed at 221114 10:59:30
2022-11-14 10:59:30 0 [Note] Plugin 'FEEDBACK' is disabled.
2022-11-14 10:59:30 0 [Note] Server socket created on IP: '::'.
2022-11-14 10:59:30 0 [Note] Reading of all Master_info entries succeeded
2022-11-14 10:59:30 0 [Note] Added new Master_info '' to hash table
2022-11-14 10:59:30 0 [Note] /opt/rh/rh-mariadb103/root/usr/libexec/mysqld: ready for connections.
Version: '10.3.35-MariaDB'  socket: '/var/lib/rh-mariadb103/mariadb.sock'  port: 3313  MariaDB Server
2022-11-14 10:59:51 8 [Warning] Access denied for user 'leantime'@'localhost' (using password: YES)

Don’t quote me on that… is loopback interface, rewire that is complicate and goes to hardware description of the system.
localhost, instead, can be “routed” elsewhere from the system changing some parameters. Still not quick to do, but without involving the change of hardware description for the OS.

oh man… left the wrong password in the config after messing around… works!!! thank you all :slight_smile:


just to finish this off. all is working, my leantime install guide for what its worth.


apache virtual host

  • neth ui → applications → webserver → virtual host
  • create virtual host
    FQDN → lean.domain.org
    require SSL encrypted connection → on
    Version of PHP → 8.0
  • copy web root path



cd /var/lib/nethserver/vhost/23b8d530ea6c4b9/config
cp configuration.sample.php configuration.php


chown -R apache:apache /var/lib/nethserver/vhost/23b8d530ea6c4b9/
chmod 755 -R /var/lib/nethserver/vhost/23b8d530ea6c4b9/


rand security key

head /dev/urandom | tr -dc A-Za-z0-9 | head -c 32 ; echo ''

vi /var/lib/nethserver/vhost/23b8d530ea6c4b9/config/configuration.php

sitename: leantime
dbUser: leantime
dbPass: KeePass
dbDatabase: leantime
seassion password -> rand security key
dbPort: 3313

public $email = 'mail@domain.org';                                   //Return email address

create db

login db103

mysql103 --user leantime -p

create db

create database leantime;
create user ‘leantime’@‘localhost’ identified by ‘keepass’;
grant all privileges on leantime.* to ‘leantime’@‘localhost’;
flush privileges;

prune db

DROP USER ‘leantime’@‘localhost’;


show databases;
SELECT User, Host FROM mysql.user;
SHOW GRANTS FOR leantime@localhost;

use leantime;
show tables;
show columns from leantime.zp_account;


systemctl -l status rh-mariadb103-mariadb
lsof -i -P -n | grep 3313
sysctl -a 2>/dev/null | grep disable_ipv6

systemctl -l restart httpd rh-mariadb103-mariadb


git clone GitHub - Leantime/docker-leantime: Official Docker Image for Leantime https://leantime.io
cd docker-leantime
docker-compose up -d

1 Like

wait, is this an alternative install method

hey, yes thats an alternative if you got docker/compose installed -i just wanted to test leant. before going through the hassle of installing it as a system service.