Latest Updates (20Dec2018) causes YumRPMCheckError

Attempting to update through Nethserver control panel generates error:

Task completed with errors
Applying changes #2 (exit status 1)
[YumRPMCheckError] [u’ERROR with transaction check vs depsolve:’, rh-php71-imagick is needed by nextcloud-15.0.0-1.el7.noarch’]

clearing Yum cache does not eliminate the problem.

The 4 updates are:


Strange this should read :

rh-php71-php-imagick is needed by nextcloud-15.0.0-1.el7.noarch

to check on your system (on the command line)

yum provides rh-php71-php-imagick

you should see sclo-php71-php-pecl-imagick-3.4.3-2.el7.x86_64 does provide this;

let’s install it:

yum install sclo-php71-php-pecl-imagick

Then go back to the server-manager and try to update your system



  1. your fix works.
  2. Regarding the name, I hand typed it, my latent mild dyslexia kicked in and I misspelled it.


1 Like

Your not alone, me too… :grinning:

Happy you are sorted out.

Could you please post the output of the following commands:

  • config show subscription
  • config show sysconfig

@mark_nl @harry I have done some test and I have the same problem.
Previously I’ve installed it only from the command line and so, for the future tests, we should go to add also this kind of test: very important to me!

I need some time to inspect the problem…

hi all and a late happy newyear!

I’ve the same issue - is there something to do - yes I read the solution above, but just to know this issue is solved or not?

And why do you see me here so seldom - well, because nethserver just works great!


Hi @maddin !

From my experience, generally, this kind of error appears when the updates are locked on current version of NS.
There are three ways to go forward:

  1. From GUI: unlock the updates, make the updates and then lock the updates.
  2. From CLI: yum clean all, yum update but this will update all, including CentOS.
  3. From CLI: HowTo update Nethserver correctly via CLI?

IMO, It’s not a big issue but is annoying.

Maybe @giacomo will solve this as he said: Yum: Failed to check for updates

Kind regards,

Thx @GG_jr

I used solution 1. - worked well!

thx all

1 Like