KVM problem with br0

NethServer Version: 7.3 final
Module: KVM
Hi everyone.
return to this tipe of topic after a while.
I’ve created a firewall with three nics, one red and the other two Green. All right.
I have installed the KVM manager to create virtual machines.
I can create virtual machines but I have problems with the network adapter in bridge.
I create the bridge from “network”, as by manual: logical card -> Brighe -> join it to one of the greem network cards and create the br0.
In WebVirtMgr, when I create the interface for the virtual machine and the association on br0 I get the following message “the pool bridge name must not contain any special characters” … Why?
If I associate the interface with any other name I go ahead but clearly my virtual hoaxes do not go online.
Someone has had these problems, do I get something trivial?
Thank you

Hi everyone.
Sorry … But nobody has ever had this problem? I made a stupid question …

Hi @roberto.schiano,

you are not alone:

I tried to reproduce it, but I couldn’t.

Maybe try changing name of the bridge br0 in webvirtmgr…or kill br0 and create a new one.

Grande Markuz …
I’m doing tests and actually, it seems to work.
I created a new bridge (br1), I deleted the bridge br0 and in WebVirtMgr I created a network adapter by attaching it to br1 I did not receive any errors.
Now I go ahead and then update.

1 Like

I did not understand why, but doing a new bridge (br1) and then deleting the old (br0), all OK.
I’ve associated the virtual NIC to br1, I did not receive any signal and the VM start regularly.
Thank you

You’re welcome. Please mark the topic as solved, if an answer worked for you:


1 Like

OK, sorry

No reason to say sorry, it’s just for helping other people having a similar problem to find the solution quickly. So it would be fine to choose a solution post that really explains the solution, which IMO is this one:

Sometimes the threads are very long so finding the problem-solving answer may be hard.