Joining a pc to the domain

activedirectory
v7

(quizhead) #1

Hi,
Can please some explain how to join a pc to the domain?
I’ve tried to look in the docs but didn’t succeed.
Is the joining automatic or do I have to add a pc manualy to the DC before attemping to join ?
If so, how do I add a pc manualy?
Thank you.


(Markus Neuberger) #2

No, you just have to install AD as account provider on Nethserver and give a password to admin.

Then clients could be joined via this admin user. The client should use NethServer as DNS server. It’s not necessary to add a pc manually.


(quizhead) #3

Adding to your reply ,I did the following:

  • I changed in the network adapter to take a random IP from the DHCP
  • I checked in the adapter details and saw the DNS-SUffix in the details

now the next question is how do I connect the PC to the domain ?
I try to connect through the System section in Control Panel but it doesn’t work.
The error is "the DNS name is not availabe"
Any suggestions ?


(Markus Neuberger) #4

If the NethServer is your DHCP server it should work. You may also try to enter the interface settings on the client manually.

Are you able to nslookup/ping the NethServer from the client?

nslookup NETHSERVER.DOMAIN.TLD
ping NETHSERVER.DOMAIN.TLD

(quizhead) #6

yes I can see the domain after ping

I tried to ping from Nethserver to the client and it failed.

What can be the reason ?

And another interesting thing : when I try the NetBios name the connection window appears and when I enter the admin credencials the same message appear about the domain inavailabilty.

Any ideas?


(Markus Neuberger) #7

Did you setup NethServer in a virtual environment? Maybe you have to allow promisc mode.
Are you able to ping your AD domain? (ping ad.domain.local) You have to join to DOMAIN.

Did you follow these steps as regards AD naming?

http://docs.nethserver.org/en/v7/accounts.html#samba-active-directory-local-provider-installation

Did you try it with IP? Maybe Windows firewall blocking ping?


(quizhead) #9

Yes I didn’t mention the VMware thing.
The promisc mode worked I suceeded joining with the netBios name but I guess it’s enough for now.
I owe you my life.