Issues with 7.6 and HyperV 16

No chance to test with vmware or proxmox on your hardware?

Not sure if this is a HW issue. If so then may be the Intel NICs.

The fresh NS install from ISO was on a Supermicro X10srm, E5-2628V4, i350 NICs

I copied the same VM to a HP DL380p Gen8 with E5-2650L V2, i350 NICs.

It’s hard to search the error given yum update does not work (issues to resolve the mirrors; network not reachable; ) which prevents me from adding tools and other modules or the linux integration services.

From time to time I can resolve the mirrors with nslookup. ifconfig looks good.

Can’t test proxmox nor vmware.

I’m not a linux guy and reached an end and will wait unitl a new kernel will be released.

1 Like

Good news: Microsoft released LIS 4.2.8 on Jan 14th which according to the release notes seem to solve my Kernel issues under HyperV16. I tried with my fresh installed test nhs 7.6 virtual machine which now gets an internet connection with Kernel 3.10.0-957.1.3.el7.x86_64. I can now run yum update and log into the Web UI.

I’m going to further test before I apply to production but looks good for now.


Tnx Thomas
After installed LIS 4.2.8 on NS 7.6, network interface work without issue with Kernel 3.10.0-957.1.3.el7.x86_64


1 Like

Hello Fabio Fusili
on nethserver and hyper-v do I need to install LIS? if you need to install LIS, how should you do it on NS7.6?



without LIS no connection no fun (at least on my HyperV16).

To Install LIS 4.2.8 download the ISO from MS and attached it as CDROM to the NS virtual maschine and mount it after boot.
mount /dev/cdrom /media
cd /media

In case you already have an old version installed then remove it from NS.

Update to the latest kernel 3.10.0-957.1.3 and reboot to ensure the kernel is active.

In case you can not ssh into NS anymore then use Hyper-V Manager and connect from there to the NS virtual machine.

Mount CDROM/iso again.

reboot (and detach cdrom).

You should be done.

I will no longer update the kernel from the software center since it most probably will damage the system until the corresponding LIS package is available.

May be the developers can add a checkbox so that we can deselect the update of the kernel.

In this case, my temporary workaround is disable and enable the network card on the vm, the network card works again until next reboot.


I solved the problems slowness and reachability via browser and ssh with the installation of LIS 4.2.8

now what happens? can I continue to update from the software center if other updates come out?

We don’t know before someone has tried. Given the experience of the last weeks I speculate a 50/50 chance that it might work flawless with a new kernel version. I wouldn’t do it on a production system. If I need to update an NS package then I go with ssh into NS and yum install . That’s what I did while I was waiting for 4.2.8. And set a checkpoint so that I can recover it easily.

On my HyperV16 (2xNS and 1 Centos native VM) Kernel 3.10.0-957.5.1 works again with LIS (released 2/12/19)


Thanks for updating us

1 Like

found some time :grin: i’m not really an hyper-v expert but:
install minimal centos 7.5 and all is working as expected
do a full update, and network is still working without lis.
install ns76 from shell, ssh and webui OK. reboot
ssh and webui ok, finish wizard still ok.
install firewall base and set static ip and all still works.
so the problem seems to show up only when upgrading ns75 to ns76… i’ll do some other tests

According to my experience neither NS76 nor standard Centos76 run smoothly (even on fresh install) as guest VM under HyperV 16 if the LIS and Kernel versions are not in sync. The issues are usually with the networking stack. It looks to me that this is not a NS specific ssue.

1 Like

i didn’t have lot of c7 on hyperv, but i’ve made some other tests, and I didn’t have problem with
c7.5 -> c7.6
with simple c7 install and webserver on it.
as soon as i install ns76 on c76 (installed or upgraded) i lost network. it seem to work only if there is only one cpu and only one queue on eth0.
changing some config on eth0 like tx or number of combined queues make it works again (also changing back to original value)
i prefer to avoid to install LIS, the built-in version are more than enough for me

so for now i have added an ETHTOOL_OPTS to ifcfg-eth (ETHTOOL_OPTS="-G {DEVICE} rx 10486; -G {DEVICE} tx 192")
and it works.
i’m not sure it’s an ns76 problem, but,
i have no errors on centos 7.6, errors start installing ns76 and no rhel or centos errata/bug (or at least i didn’t find it)…


@dz00te could you please have a look at this issue?

More details about the implementation are in the PR:

I understand that the HyperV problems seem different, but maybe udev is triggered again and it puts down the network cards.

1 Like

thank you for the input i miss this issue… in effect, it seems that simply commenting the line in /etc/udev/rules.d/95-NetworksDB.rules make it work all again. I hope to have some time this afternoon to make some other tests and check the script. tnx

i’m sorry to not have some time to test properly… anyway, after the latest upgrade of nethserver-base it seems to work without any trick :+1:
i’ve also made an install of ns76 over a c76, i had to reboot to access, but honestly, i didn’t remeber if the vm i used was used for other tests,so i’ll retry with a clean install tomorrow

confirmed, installing ns76 from plain centos bring down the eth0, a simple reboot solve the problem

Bump up…
New kernel has been released by CentOS, 3.10.957.10.1.
Microsoft released 4.2.8-2 version of LIS on 04 of March
Consider if diligent the update before the kernel update of the guest…

Microsoft stated necessary LIS 4.2 for any 7.x version of CentOS.


NS with Kernel 3.10.957.10.1. and Microsoft LIS LIS 4.3 works fine as a guest in my HyperV Server 2016 set-up (Xeon E5-2618Lv4)