Issue Configuring Nethserver With 2 NIC Cards

testing

(Luv Maloo) #1

Howdy!

I’am trying to configure 2 NIC cards on Nethserver; the WAN link connects to eth0 directly & want to use eth1 as DHCP for the LAN local users; screenshot below. Along with this I’ve installed all packages (except the language) & system is upto date.

Later, I created a DHCP pool as well:

Now the issue is, I 'am able to access & SSH the WAN IP remotely & executed ping & traceroute with any issues but if try to access internet using eth1 (laptop connected to the port via ethernet cable), it doesn’t work at all :open_mouth: :frowning:

Am I missing something here?? :expressionless:


#2

Hi,

When you connect your laptop on eth1…
It take an ip from the DHCP, or not?


(Luv Maloo) #4

No it’s not taking IP address from DHCP but getting the default 169.254.0.0 :expressionless:


(Gabriel GHEORGHIU) #5

Do you use a crossover patch cord?

Is your laptop NIC set to Automatic (DHCP)?


(Luv Maloo) #6

Yes using crossover patch chord, & did try with automatic DHCP enabled on my laptop & manually configured DHCP as well but no joy.


(Freddy Brignardello) #7

I do not remember that distribution had that problem.
Finish changing the network card.
Proba with another model of network card.
If I remember it was a plate of old network was abandoned and wanted to try it … headaches gave me … I changed the card and fixed.


(Luv Maloo) #8

@Freddy_Brignardello But both of the Network cards are working with Zentyal system perfectly fine :open_mouth:


(Gabriel GHEORGHIU) #9

Please try a normal patch cord. If the NICs are MDI-X or Gigabit, you don’t need a crossover cable.

Do you have link?


(Luv Maloo) #10

@GG_jr Ok - let me visit office tomorrow, 'll check and revert… Thanks :smile:


(Luv Maloo) #11

Hey Guys,

It worked post re-configuring the Network element, DHCP & DNS; provided WAN IP to eth0 & connected router to eth1 (LAN part) and users are able to access internet; did try couple of firewall commands and its working fine :smiley:


(Alessio Fattorini) #12

Good, choose your answer and check resolved :slight_smile: