IP after the installation

Continue the game with anaconda if you set a static IP but if you don’t enable your NIC in the network panel of anaconda, then the IP you want is not set and you end with a default IP at your first boot

Of course your server is not reachable in your network.

@dev_team I really don’t know how to do it, but the installer should enable the nic and set the correct IP

If I enable the NIC then the IP is set but I have another problem with a strange dns entry.

Wrong dns IPV6 entry with a NS7.3 fresh Install

If you use the unattended or interactive installation the installer will do it for you.
Otherwise is a matter between the user and the bad Anaconda UI :smiley:

Yes, it’s a fallback and it exists since NS 6 ( http://docs.nethserver.org/en/v7rc/installation.html#fallback-ip-configuration )

Sadly this can only be documented:


Under the Network > General section, only the interfaces marked as Automatically connect to this network when it is available are enabled at boot in the installed system. For more info, refer to RHEL 7 installation guide.

So we have to settle for a workaround. Annoying, but if you are aware of it, you won’t have too much trouble fixing after first reboot. Just make sure you can reach the configured interface after reboot and you can change the settings through NethServer webinterface.