Installing Horde Groupware

which outlook, FTR?

activesync is supported only from Outlook 2013 onwards

Thanks for your answer @Stefano_Zamboni,
it’s Outlook 2013 and I choose manual configuration and connect with outlook.com or other compatible Exchange ActiveSync Service.
I get an error message, that the name at the certificate (the name is Nethserver) is not the same as the internet page. I can continue with yes. After continuing I get the message:

Sign in at ActiveSync-e-mail-server (EAS): Server wasn’t found.

in this case, the only thing that can help you is to dig into the logs

Ok, I activate the activesync logs at the config and have a look for it. I’ll be back later.

I can’t find anything at the logs. Enabled activesync.log at horde, but the file is not created. Client logs (windows) aren’t helpful too. At messages and horde log I can’t find anything either.

I tried it and finally it did not really work.

I created /etc/httpd/conf.d/horde.conf with following content I found in the horde wiki

Alias /Microsoft-Server-ActiveSync /usr/share/horde/rpc.php
Alias /autodiscover/autodiscover.xml /usr/share/horde/rpc.php
Alias /Autodiscover/Autodiscover.xml /usr/share/horde/rpc.php
Alias /AutoDiscover/AutoDiscover.xml /usr/share/horde/rpc.php

Then I restarted httpd

systemctl restart httpd

After that Outlook 16 can connect but does not see mails and Android Samsung mail can’t connect but the device is shown at horde admin panel. Outlook is shown too.

I’ll test some more the next days …maybe there’s a chance to get it to work.

2 Likes

Contacts and calendars are working with Outlook 2016 and Nine on Android! :sunglasses:

Sending mails works but the mails in the folders are not shown. As a workaround one may setup a separate IMAP account.

/etc/httpd/conf.d/horde.conf:

Alias /Microsoft-Server-ActiveSync /usr/share/horde/rpc.php
Alias /autodiscover/autodiscover.xml /usr/share/horde/rpc.php
Alias /Autodiscover/Autodiscover.xml /usr/share/horde/rpc.php
Alias /AutoDiscover/AutoDiscover.xml /usr/share/horde/rpc.php
RewriteEngine On
#RewriteRule ^/Microsoft-Server-ActiveSync /usr/share/horde/rpc.php [PT,L,QSA]
RewriteRule .* - [E=HTTP_MS_ASPROTOCOLVERSION:%{HTTP:Ms-Asprotocolversion}]
RewriteRule .* - [E=HTTP_X_MS_POLICYKEY:%{HTTP:X-Ms-Policykey}]
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

ActiveSync settings:

$conf['activesync']['params']['driverconfig'] = 'horde';
$conf['activesync']['storage'] = 'Sql';
$conf['activesync']['emailsync'] = true;
$conf['activesync']['version'] = '14.1';
$conf['activesync']['auth']['type'] = 'basic';
$conf['activesync']['autodiscovery'] = 'user';
$conf['activesync']['outlookdiscovery'] = false;
$conf['activesync']['logging']['path'] = '/var/log/horde/activesync.log';
$conf['activesync']['logging']['type'] = 'onefile';
$conf['activesync']['ping']['heartbeatmin'] = 60;
$conf['activesync']['ping']['heartbeatmax'] = 2700;
$conf['activesync']['ping']['heartbeatdefault'] = 480;
$conf['activesync']['ping']['deviceping'] = true;
$conf['activesync']['ping']['waitinterval'] = 15;
$conf['activesync']['enabled'] = true;

I get an error in /var/log/horde/activesync.log when syncing mails, I tried playing with horde permissions but no success:

[53228][2018-06-28T22:50:56+00:00] >>>: Polling Horde_Core_ActiveSync_Driver::_getMailFolders()
[53228][2018-06-28T22:50:56+00:00] ERR: User markus is not authorized for Mail

Hi Markus,
I’ve found something with a cyrus-imap, how I know dovecot is based on it.

For now, i’ve disabled the BINARY capability in the imp backend
configuration using:
$servers[‘advanced’][‘capability_ignore’] = array(‘BINARY’);

Have a look here:

https://lists.horde.org/archives/horde/Week-of-Mon-20140224/050740.html

1 Like

Have to dig deep in my memory; had to deal with this before, and of course not sure if it is the same issue. And it was the root of the inbox-box; are the incoming mails stored in root (/) of the mailbox or inside the subfolder /INBOX. IIRC you can solve it with an alias namespace in dovecots configuration.

This also solves quite some troubles with (older)android; It favors the “cyrus-imap way” which is storing incoming in /INBOX, IIRC dovecot as configured on NS stores incoming in in the root (/) of the mailbox.

Just a lead…

EDIT:
I knew i wrote it down somewhere : https://github.com/markVnl/nethserver-sogo/issues/5

EDIT2:
although this is not the issue, just yo be accurate :grin:

1 Like

Thanks @m.traeumner and @mark_nl, I found the error.

Creating a file /usr/share/horde/imp/config/backends.local.php with following content solved it. It was already discussed here, I just missed it. Now mails, calendars and contacts are working in Outlook and Nine.

$servers['imap'] = array(
    // ENABLED by default; will connect to IMAP port on local server
    'disabled' => false,
    'name' => 'IMAP Server',
    'hostspec' => 'localhost',
    'hordeauth' => true,
    'protocol' => 'imap',
    'port' => 143,   
    'secure' => 'tls',
);
1 Like

Just create these two files and the mail address is auto populated at first login:

/usr/share/horde/config/prefs.local.php:

<?php
 $_prefs['from_addr']['hook'] = true;
 $_prefs['fullname']['hook'] = true;

/usr/share/horde/config/hooks.local.php:

<?php
class Horde_Hooks
{
    public function prefs_init($pref, $value, $username, $scope_ob)
    {
        switch ($pref) {
        case 'from_addr':
            if (is_null($username)) {
                return $value;
            }
            $mail = $username.'@domain.local';
            return empty($mail)
                ? ''
                : $mail;

        case 'fullname':
            if (is_null($username)) {
                return $value;
            }
            return empty($username)
                ? ''
                : $username;
        }
    }
}

I just adapted the script from https://wiki.horde.org/LDAPHooksHorde5

2 Likes

Hello,

I’ve been trying to configure this part but without success. Appears my hooks are ignored…

Can you help me?

Are you running Nethserver 7.6?
Do you use LDAP or Active Directory?

Hi,

I’m using centos 7.5, my environment have the following setup:

  • Server 1: Horde Groupware 5.2.22 (centos 7.5)

  • Server 2: OpenLap, used to get my Address Book

  • Server 3: IMAP Server (Dovecot, postfix)

I have doubts with my authentication method, I have the option “Let a Horde application handle authentication” , this is a problem?

I want to auto-populate the Mail preferences/Personal information for my users. For that I’ve tried to follow your documentation and this documentation https://wiki.horde.org/LDAPHooksHorde5 but without success :frowning:

Thank you.

Are you using Nethserver 7.5, or a plain CentOS installation? If the latter, this forum really isn’t the place for your questions.

I’m plain CentOS installation. Im’ sorry, I didn’t know :frowning:

If you like CentOS, why not try Nethserver, it’s based on and installable from CentOS, see the docs.

Nethserver Horde implementation works with AD/LDAP (addressbook) but IMAP login is used.

1 Like

Thank you for your suggestion but at this time I have to do only with CentOS, maybe later I will try the Nethserver. The Horde installation and configuration of the for CentOS is the same as Nethserver, I will see you steps with more careful and compare with my configurations.

Thank you

2 Likes

Anyone that have made Horde work with PHP 7.3 on Nethserver? I have been using Horde for years and also my users so I’m searching for a solution. I have also tried the steps described here: https://community.nethserver.org/t/horde-issues-before-to-release/17141/9. But I’m completly stuck on getting activesync to work. It throws an 401 error with username/password is wrong. Even with debug set in log level there is not enough information find out whats wrong. The exact same conf-file for activesync works with php 5.4. So any tip would be helpful

Hi and welcome to NethServer community.

Did you already try to configure the activesync settings manually in the horde web UI?

Did you enable activesync? /etc/httpd/conf.d/horde.conf should contain the following:

Alias /Microsoft-Server-ActiveSync /usr/share/horde/rpc.php
Alias /autodiscover/autodiscover.xml /usr/share/horde/rpc.php
Alias /Autodiscover/Autodiscover.xml /usr/share/horde/rpc.php
Alias /AutoDiscover/AutoDiscover.xml /usr/share/horde/rpc.php

RewriteEngine On
RewriteRule .* - [E=HTTP_MS_ASPROTOCOLVERSION:%{HTTP:Ms-Asprotocolversion}]
RewriteRule .* - [E=HTTP_X_MS_POLICYKEY:%{HTTP:X-Ms-Policykey}]
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

To enable it (it rewrites all related horde config files so maybe keep a backup):

config setprop horde activesync enabled

Apply config:

signal-event nethserver-horde-update

1 Like