Installation of nethserver 7.3 fail

I recall some odd issues with anaconda during the partition time, and they have been solved by blanking the partition table ‘dd if=/dev/null of=/dev/sdX’

i had similar problem, the only workaround was to install centos and after that nethserver.

yum localinstall -y


gg :slight_smile:


This is the only way it worked. Thank you very much @ssabbath!

So… i did install centos 7 (from nethserver dvd)… then i installed nethserver like @ssabbath described… but nethserver gives me errors. the first time i accesed software center i got an error about the firewall (something about the logs)… i restarted the server but after that everytime i access software center it’s giving me error, asking me to clear the cache, which i did but with no luck.
So I’m stucked. I think there is a problem with rc3.
And i see another error “failed to register logger”…
I will try to install rc2 (because this one worked) and see what happens.

This one is due to this:

The other one could be related to a networking problem (dns, no Internet access…)

go to the terminal, please do and report the outputs

ip addr
ip route

It really looks like a ip config error. A network problem.

Or, maybe, looking in the first error, a memory problem. Try passing some loops of memtest.

I gave up RC 3 and went to RC4. I had initialy the same problems installing it. It was a hardware related problem (I think it was a problem with my raid controller dell perc 730 mini and nethserver)… Strange but the only solution I found was to delete the raid array, rebuilt it as raid 10, initialize it, power off server, wait for one day and after that it worked… ONLY delete the raid array, rebuilt it as raid 10, initialize it, AND delete the raid array, rebuilt it as raid 10, initialize it and power off didn’t work…

The only solution was to wait one day with the server powered off. After that it worked. I know that maybe you will laugh… i know it doesn’t have any logic… but still… this was the only way it worked.

Thank you all for your help.

In RC4 I found some problems with software center and/or clamav. I created another topic for that.

Liviu, it is possible that a cache or battery of the controller to be the reason.
Also you can try a firmware upgrade. check cables slots etc.


Checked the battery… 100%
About the cache… shouldn’t it be cleared on system restart/power on? (it’s a question because I’m not sure about that)
Maybe a firmware upgrade would work but on the other hand on a standard centos minimal install I had no problem. That is strange because there is a minimum difference between a standard centos install and a nethserver install (i think in centos install you have to choose the language and in nethserver you don’t).

Anyway i managed to install nethserver and that is what matters.

I`m just facing same problem, try the method by @ssabbath also not work [quote=“ssabbath, post:23, topic:5383”]
i had similar problem, the only workaround was to install centos and after that nethserver.

yum localinstall -y


gg :slight_smile:

Just in case you facing some problem with me, you can fix this with using centos raid option.

Put your bios sata mode in AHCi, and install Nethserver using centos raid just solved my problem.

hope it helps.

@makadang, you realize this topic is almost 1 year old and about NethServer 7.3?
Do you try to install NS7.3? Then I strongly advise you to download the latest version NS 7.4
If you still encounter problems, please open a new topic where you give as much as possible info about your hardware, environment, etc… so we can help you.

@robb sorry my friend, I realize but i find this thread by google so i put my reply here since it related to the thread and maybe more easy to find. I use 7.4 final version of Nethserver and this issue still happen when installing using fake raid.

Hi @makadang ,

I didn’t try to install NS 7.4 so i don’t know what to say. If it’s the same problem you will find my solution above. Like i said…i think it’s a hardware (raid) problem or something in the nethserver installation (maybe the time required to detect the raid should be increased)

I did also face the same problem in a old HP mini-server with 7.4 :frowning:

Something about partitioning in nethserver installation isn´t always working with some old servers :stuck_out_tongue:

I noticed similar behavior. But I doubt this is a NethServer problem, but more an Anaconda/CentOS upstream problem.


O yeah… sorry, that was what i meant… Anyway, i don´t know why when i install first centos and then nethserver it works…

1 Like

I belive it’s a nethserver error because installing centos returns no error.

I had the same problem here with Nethserver 7.5 (Dell R320) to solve it I de-select the USB stick in the partition menu and establish the local (USB) repositorie.

After that I’m able to re-install with new hard drives.