Install failed due to metadata caching issues

hi!
can’t install “SoGo Groupware” on fresh installed Nethserver 6.8 (all updates installed)
"Resolving RPM dependencies
The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation."
Already tried to clear cache, same error…
regards

Resolving RPM dependencies
The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation.

I cleared it 4 time and still get the same error, try to install the file server with samba and no luck
please help. Also I see no way of adding users…

I’m doing some tests from NethServer 6.8 to verify they are reporting failure

2 Likes

i tried this solution: NethServer 6.8 "Final" released!
it seem to work for me

I just made the installation, when installing software from the center fails dependencies.

But when doing the installation by ssh, everything was installed without problems.

josegjimenez@HARDSOFT-M2421:~$ ssh -p 2222 root@192.168.60.180
root@192.168.60.180’s password:
Last login: Mon Jun 20 20:47:25 2016 from 192.168.60.143

************ Welcome to NethServer ************

This is a NethServer installation.

Before editing configuration files, be aware
of the automatic events and templates system.

      http://docs.nethserver.org

[root@localhost ~]# yum install nethserver-sogo
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Setting up Install Process
Loading mirror speeds from cached hostfile

  • centos-base: mirror.us.leaseweb.net
  • centos-updates: mirror.us.leaseweb.net
  • nethforge: nethserver.de-labrusse.fr
  • nethserver-base: nethserver.de-labrusse.fr
  • nethserver-updates: nethserver.de-labrusse.fr
    Resolving Dependencies
    –> Running transaction check
    —> Package nethserver-sogo.noarch 0:1.5.6-1.ns6 will be installed
    –> Processing Dependency: sogo >= 2.3.0 for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: nethserver-mysql >= 1.0.0 for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: nethserver-memcached >= 1.0.0 for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: nethserver-mail-server >= 1.1.0-2 for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: nethserver-httpd >= 1.0.1-2 for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: sope49-gdl1-mysql for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: sogo-tool for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: sogo-activesync for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: perl(esmith::AccountsDB) for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: perl(NethServer::Directory) for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Processing Dependency: libwbxml for package: nethserver-sogo-1.5.6-1.ns6.noarch
    –> Running transaction check
    —> Package libwbxml.x86_64 0:0.11.2-4.centos6 will be installed
    —> Package nethserver-directory.noarch 0:2.3.0-1.ns6 will be installed
    –> Processing Dependency: perl-LDAP = 1:0.40-2.nh for package: nethserver-directory-2.3.0-1.ns6.noarch
    –> Processing Dependency: pam_ldap >= 185-5 for package: nethserver-directory-2.3.0-1.ns6.noarch
    –> Processing Dependency: nss-pam-ldapd >= 0.7.5-3 for package: nethserver-directory-2.3.0-1.ns6.noarch
    –> Processing Dependency: perl(Net::LDAP::LDIF) for package: nethserver-directory-2.3.0-1.ns6.noarch
    –> Processing Dependency: perl(Net::LDAP) for package: nethserver-directory-2.3.0-1.ns6.noarch
    –> Processing Dependency: perl(MIME::Entity) for package: nethserver-directory-2.3.0-1.ns6.noarch
    –> Processing Dependency: perl(Authen::SASL) for package: nethserver-directory-2.3.0-1.ns6.noarch
    –> Processing Dependency: openldap-servers for package: nethserver-directory-2.3.0-1.ns6.noarch
    –> Processing Dependency: openldap-clients for package: nethserver-directory-2.3.0-1.ns6.noarch
    —> Package nethserver-httpd.noarch 0:2.5.3-1.ns6 will be installed
    —> Package nethserver-mail-server.noarch 0:1.9.2-1.ns6 will be installed
    –> Processing Dependency: nethserver-mail-common > 1.4.1-1 for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: dovecot-pigeonhole >= 2.1.16 for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: dovecot-deleted-to-trash >= 0.6 for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: dovecot-antispam >= 0.0.49-1 for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: dovecot >= 2.1.16 for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: perl(Text::Unidecode) for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: cyrus-sasl-plain for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: cyrus-sasl-ntlm for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: cyrus-sasl-md5 for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    –> Processing Dependency: cyrus-sasl-ldap for package: nethserver-mail-server-1.9.2-1.ns6.noarch
    —> Package nethserver-memcached.noarch 0:1.0.2-1.ns6 will be installed
    –> Processing Dependency: memcached for package: nethserver-memcached-1.0.2-1.ns6.noarch
    —> Package nethserver-mysql.noarch 0:1.0.7-1.ns6 will be installed
    –> Processing Dependency: perl-Expect for package: nethserver-mysql-1.0.7-1.ns6.noarch
    –> Processing Dependency: mysql-server for package: nethserver-mysql-1.0.7-1.ns6.noarch
    —> Package sogo.x86_64 0:2.3.10-1.centos6 will be installed
    –> Processing Dependency: sope49-gdl1-contentstore >= 2.3.10 for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: sope49-cards >= 2.3.10 for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: gnustep-base >= 1.23 for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: zip for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: sope49-sbjson for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: sope49-ldap for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: sope49-core for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: sope49-appserver for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: libmemcached for package: sogo-2.3.10-1.centos6.x86_64
    –> Processing Dependency: lasso for package: sogo-2.3.10-1.centos6.x86_64
    —> Package sogo-activesync.x86_64 0:2.3.10-1.centos6 will be installed
    —> Package sogo-tool.x86_64 0:2.3.10-1.centos6 will be installed
    —> Package sope49-gdl1-mysql.x86_64 0:4.9-20160405_1664.el6.1 will be installed
    –> Processing Dependency: sope49-gdl1 for package: sope49-gdl1-mysql-4.9-20160405_1664.el6.1.x86_64
    –> Running transaction check
    —> Package cyrus-sasl-ldap.x86_64 0:2.1.23-15.el6_6.2 will be installed
    —> Package cyrus-sasl-md5.x86_64 0:2.1.23-15.el6_6.2 will be installed
    —> Package cyrus-sasl-ntlm.x86_64 0:2.1.23-15.el6_6.2 will be installed
    —> Package cyrus-sasl-plain.x86_64 0:2.1.23-15.el6_6.2 will be installed
    —> Package dovecot.x86_64 1:2.1.16-1.el6 will be installed
    —> Package dovecot-antispam.x86_64 0:0.0.49-1.ns6 will be installed
    —> Package dovecot-deleted-to-trash.x86_64 0:0.6-2.ns6 will be installed
    —> Package dovecot-pigeonhole.x86_64 1:2.1.16-1.el6 will be installed
    —> Package gnustep-base.x86_64 0:1.23.0-1 will be installed
    –> Processing Dependency: gnustep-make >= 2.6.0 for package: gnustep-base-1.23.0-1.x86_64
    –> Processing Dependency: libobjc.so.2()(64bit) for package: gnustep-base-1.23.0-1.x86_64
    —> Package lasso.x86_64 0:2.4.0-6.el6 will be installed
    –> Processing Dependency: libxmlsec1.so.1()(64bit) for package: lasso-2.4.0-6.el6.x86_64
    –> Processing Dependency: libxmlsec1-openssl.so.1()(64bit) for package: lasso-2.4.0-6.el6.x86_64
    –> Processing Dependency: libltdl.so.7()(64bit) for package: lasso-2.4.0-6.el6.x86_64
    —> Package libmemcached.x86_64 0:1.0.18-1 will be installed
    —> Package memcached.x86_64 0:1.4.4-3.el6 will be installed
    –> Processing Dependency: libevent-1.4.so.2()(64bit) for package: memcached-1.4.4-3.el6.x86_64
    —> Package mysql-server.x86_64 0:5.1.73-7.el6 will be installed
    –> Processing Dependency: mysql = 5.1.73-7.el6 for package: mysql-server-5.1.73-7.el6.x86_64
    –> Processing Dependency: perl-DBI for package: mysql-server-5.1.73-7.el6.x86_64
    –> Processing Dependency: perl-DBD-MySQL for package: mysql-server-5.1.73-7.el6.x86_64
    –> Processing Dependency: perl(DBI) for package: mysql-server-5.1.73-7.el6.x86_64
    —> Package nethserver-mail-common.noarch 0:1.5.5-1.ns6 will be installed
    –> Processing Dependency: amavisd-new >= 2.8.0-4 for package: nethserver-mail-common-1.5.5-1.ns6.noarch
    –> Processing Dependency: perl-Convert-BinHex for package: nethserver-mail-common-1.5.5-1.ns6.noarch
    —> Package nss-pam-ldapd.x86_64 0:0.7.5-32.el6 will be installed
    –> Processing Dependency: nscd for package: nss-pam-ldapd-0.7.5-32.el6.x86_64
    —> Package openldap-clients.x86_64 0:2.4.40-12.el6 will be installed
    —> Package openldap-servers.x86_64 0:2.4.40-12.el6 will be installed
    –> Processing Dependency: portreserve for package: openldap-servers-2.4.40-12.el6.x86_64
    —> Package pam_ldap.x86_64 0:185-11.el6 will be installed
    —> Package perl-Authen-SASL.noarch 0:2.13-3.el6 will be installed
    –> Processing Dependency: perl(GSSAPI) for package: perl-Authen-SASL-2.13-3.el6.noarch
    –> Processing Dependency: perl(Digest::HMAC_MD5) for package: perl-Authen-SASL-2.13-3.el6.noarch
    —> Package perl-Expect.noarch 0:1.21-3.el6 will be installed
    –> Processing Dependency: perl(IO::Pty) >= 1.03 for package: perl-Expect-1.21-3.el6.noarch
    –> Processing Dependency: perl(IO::Tty) for package: perl-Expect-1.21-3.el6.noarch
    —> Package perl-LDAP.noarch 1:0.40-2.nh will be installed
    –> Processing Dependency: perl(XML::SAX::Writer) for package: 1:perl-LDAP-0.40-2.nh.noarch
    –> Processing Dependency: perl(XML::SAX::Base) for package: 1:perl-LDAP-0.40-2.nh.noarch
    –> Processing Dependency: perl(IO::Socket::SSL) for package: 1:perl-LDAP-0.40-2.nh.noarch
    –> Processing Dependency: perl(Convert::ASN1) for package: 1:perl-LDAP-0.40-2.nh.noarch
    —> Package perl-MIME-tools.noarch 0:5.427-4.el6 will be installed
    –> Processing Dependency: perl(Mail::Internet) >= 1.28 for package: perl-MIME-tools-5.427-4.el6.noarch
    –> Processing Dependency: perl(Mail::Header) >= 1.06 for package: perl-MIME-tools-5.427-4.el6.noarch
    –> Processing Dependency: perl(Mail::Field) >= 1.05 for package: perl-MIME-tools-5.427-4.el6.noarch
    –> Processing Dependency: perl(IO::ScalarArray) >= 1.114 for package: perl-MIME-tools-5.427-4.el6.noarch
    –> Processing Dependency: perl(Mail::Send) for package: perl-MIME-tools-5.427-4.el6.noarch
    –> Processing Dependency: perl(Mail::Field) for package: perl-MIME-tools-5.427-4.el6.noarch
    –> Processing Dependency: perl(IO::ScalarArray) for package: perl-MIME-tools-5.427-4.el6.noarch
    –> Processing Dependency: perl(IO::Lines) for package: perl-MIME-tools-5.427-4.el6.noarch
    –> Processing Dependency: perl(IO::InnerFile) for package: perl-MIME-tools-5.427-4.el6.noarch
    —> Package perl-Text-Unidecode.noarch 0:0.04-7.1.el6 will be installed
    —> Package sope49-appserver.x86_64 0:4.9-20160405_1664.el6.1 will be installed
    –> Processing Dependency: sope49-xml for package: sope49-appserver-4.9-20160405_1664.el6.1.x86_64
    –> Processing Dependency: sope49-mime for package: sope49-appserver-4.9-20160405_1664.el6.1.x86_64
    —> Package sope49-cards.x86_64 0:2.3.10-1.centos6 will be installed
    —> Package sope49-core.x86_64 0:4.9-20160405_1664.el6.1 will be installed
    —> Package sope49-gdl1.x86_64 0:4.9-20160405_1664.el6.1 will be installed
    —> Package sope49-gdl1-contentstore.x86_64 0:2.3.10-1.centos6 will be installed
    —> Package sope49-ldap.x86_64 0:4.9-20160405_1664.el6.1 will be installed
    —> Package sope49-sbjson.x86_64 0:2.3.1-20160405_1664.el6.1 will be installed
    —> Package zip.x86_64 0:3.0-1.el6_7.1 will be installed
    –> Running transaction check
    —> Package amavisd-new.noarch 0:2.9.1-2.el6 will be installed
    –> Processing Dependency: unzoo for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Unix::Syslog) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Socket6) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Razor2::Client::Version) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Net::SSLeay) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Net::DNS) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Mail::SpamAssassin) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Mail::SPF) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Mail::DKIM) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(IO::Socket::INET6) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Digest::SHA1) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(DBD::SQLite) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Crypt::OpenSSL::RSA) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Convert::UUlib) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Convert::TNEF) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(BerkeleyDB) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Archive::Zip) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: perl(Archive::Tar) for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: p7zip-plugins for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: p7zip for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: nomarch for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: lzop for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: lrzip for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: freeze for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: clamd for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: cabextract for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: arj for package: amavisd-new-2.9.1-2.el6.noarch
    –> Processing Dependency: altermime for package: amavisd-new-2.9.1-2.el6.noarch
    —> Package gnustep-make.x86_64 0:2.6.1-1 will be installed
    —> Package libevent.x86_64 0:1.4.13-4.el6 will be installed
    —> Package libobjc.x86_64 0:4.4.7-17.el6 will be installed
    —> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
    —> Package mysql.x86_64 0:5.1.73-7.el6 will be installed
    —> Package nscd.x86_64 0:2.12-1.192.el6 will be installed
    —> Package perl-Convert-ASN1.noarch 0:0.22-1.el6.rfx will be installed
    —> Package perl-Convert-BinHex.noarch 0:1.119-10.1.el6 will be installed
    —> Package perl-DBD-MySQL.x86_64 0:4.013-3.el6 will be installed
    —> Package perl-DBI.x86_64 0:1.609-4.el6 will be installed
    —> Package perl-Digest-HMAC.noarch 0:1.01-22.el6 will be installed
    —> Package perl-GSSAPI.x86_64 0:0.26-6.el6 will be installed
    —> Package perl-IO-Socket-SSL.noarch 0:1.44-1.el6.rfx will be installed
    —> Package perl-IO-Tty.x86_64 0:1.08-4.el6 will be installed
    —> Package perl-IO-stringy.noarch 0:2.110-10.1.el6 will be installed
    —> Package perl-MailTools.noarch 0:2.04-4.el6 will be installed
    —> Package perl-XML-SAX.noarch 0:0.96-7.el6 will be installed
    –> Processing Dependency: perl(XML::NamespaceSupport) for package: perl-XML-SAX-0.96-7.el6.noarch
    –> Processing Dependency: perl(XML::LibXML::Common) for package: perl-XML-SAX-0.96-7.el6.noarch
    –> Processing Dependency: perl(XML::LibXML) for package: perl-XML-SAX-0.96-7.el6.noarch
    —> Package perl-XML-SAX-Writer.noarch 0:0.50-8.el6 will be installed
    –> Processing Dependency: perl(XML::Filter::BufferText) for package: perl-XML-SAX-Writer-0.50-8.el6.noarch
    –> Processing Dependency: perl(Text::Iconv) for package: perl-XML-SAX-Writer-0.50-8.el6.noarch
    —> Package portreserve.x86_64 0:0.0.4-11.el6 will be installed
    —> Package sope49-mime.x86_64 0:4.9-20160405_1664.el6.1 will be installed
    —> Package sope49-xml.x86_64 0:4.9-20160405_1664.el6.1 will be installed
    —> Package xmlsec1.x86_64 0:1.2.20-4.el6 will be installed
    —> Package xmlsec1-openssl.x86_64 0:1.2.20-4.el6 will be installed
    –> Running transaction check
    —> Package altermime.x86_64 0:0.3.10-3.el6 will be installed
    —> Package arj.x86_64 0:3.10.22-22.el6 will be installed
    —> Package cabextract.x86_64 0:1.4-1.el6.rf will be installed
    —> Package clamd.x86_64 0:0.99-3.el6 will be installed
    –> Processing Dependency: clamav = 0.99-3.el6 for package: clamd-0.99-3.el6.x86_64
    –> Processing Dependency: libclamav.so.7(CLAMAV_PUBLIC)(64bit) for package: clamd-0.99-3.el6.x86_64
    –> Processing Dependency: libclamav.so.7(CLAMAV_PRIVATE)(64bit) for package: clamd-0.99-3.el6.x86_64
    –> Processing Dependency: libclamav.so.7()(64bit) for package: clamd-0.99-3.el6.x86_64
    —> Package freeze.x86_64 0:2.5.0-11.el6 will be installed
    —> Package lrzip.x86_64 0:0.614-1.el6 will be installed
    –> Processing Dependency: liblzo2.so.2()(64bit) for package: lrzip-0.614-1.el6.x86_64
    —> Package lzop.x86_64 0:1.02-0.9.rc1.el6 will be installed
    —> Package nomarch.x86_64 0:1.4-6.el6 will be installed
    —> Package p7zip.x86_64 0:9.20.1-2.el6 will be installed
    —> Package p7zip-plugins.x86_64 0:9.20.1-2.el6 will be installed
    —> Package perl-Archive-Tar.x86_64 0:1.58-141.el6_7.1 will be installed
    –> Processing Dependency: perl(Package::Constants) for package: perl-Archive-Tar-1.58-141.el6_7.1.x86_64
    –> Processing Dependency: perl(IO::Zlib) for package: perl-Archive-Tar-1.58-141.el6_7.1.x86_64
    —> Package perl-Archive-Zip.noarch 0:1.30-2.el6 will be installed
    —> Package perl-BerkeleyDB.x86_64 0:0.43-3.el6 will be installed
    —> Package perl-Convert-TNEF.noarch 0:0.18-1.el6.rf will be installed
    —> Package perl-Convert-UUlib.x86_64 2:1.4-1.el6 will be installed
    —> Package perl-Crypt-OpenSSL-RSA.x86_64 0:0.25-10.1.el6 will be installed
    –> Processing Dependency: perl(Crypt::OpenSSL::Random) for package: perl-Crypt-OpenSSL-RSA-0.25-10.1.el6.x86_64
    –> Processing Dependency: perl(Crypt::OpenSSL::Bignum) for package: perl-Crypt-OpenSSL-RSA-0.25-10.1.el6.x86_64
    —> Package perl-DBD-SQLite.x86_64 0:1.27-3.el6 will be installed
    —> Package perl-Digest-SHA1.x86_64 0:2.12-2.el6 will be installed
    —> Package perl-IO-Socket-INET6.noarch 0:2.56-4.el6 will be installed
    —> Package perl-Mail-DKIM.noarch 0:0.37-2.el6 will be installed
    —> Package perl-Mail-SPF.noarch 0:2.8.0-2.el6 will be installed
    –> Processing Dependency: perl(Error) for package: perl-Mail-SPF-2.8.0-2.el6.noarch
    —> Package perl-Net-DNS.x86_64 0:0.65-5.el6 will be installed
    —> Package perl-Net-SSLeay.x86_64 0:1.36-1.el6.rfx will be installed
    —> Package perl-Razor-Agent.x86_64 0:2.85-6.el6 will be installed
    —> Package perl-Socket6.x86_64 0:0.23-4.el6 will be installed
    —> Package perl-Text-Iconv.x86_64 0:1.7-6.el6 will be installed
    —> Package perl-Unix-Syslog.x86_64 0:1.1-3.el6 will be installed
    —> Package perl-XML-Filter-BufferText.noarch 0:1.01-8.el6 will be installed
    —> Package perl-XML-LibXML.x86_64 1:1.70-5.el6 will be installed
    —> Package perl-XML-NamespaceSupport.noarch 0:1.11-1.el6.rfx will be installed
    —> Package spamassassin.x86_64 0:3.4.1-7.el6 will be installed
    –> Processing Dependency: procmail for package: spamassassin-3.4.1-7.el6.x86_64
    –> Processing Dependency: perl(Net::CIDR::Lite) for package: spamassassin-3.4.1-7.el6.x86_64
    –> Processing Dependency: perl(Geo::IP) for package: spamassassin-3.4.1-7.el6.x86_64
    –> Processing Dependency: perl(ExtUtils::MakeMaker) for package: spamassassin-3.4.1-7.el6.x86_64
    –> Processing Dependency: perl(Encode::Detect) for package: spamassassin-3.4.1-7.el6.x86_64
    —> Package unzoo.x86_64 0:4.4-7.el6 will be installed
    –> Running transaction check
    —> Package clamav.x86_64 0:0.99-3.el6 will be installed
    –> Processing Dependency: clamav-db = 0.99-3.el6 for package: clamav-0.99-3.el6.x86_64
    —> Package lzo.x86_64 0:2.03-3.1.el6_5.1 will be installed
    —> Package perl-Crypt-OpenSSL-Bignum.x86_64 0:0.04-8.1.el6 will be installed
    —> Package perl-Crypt-OpenSSL-Random.x86_64 0:0.04-9.1.el6 will be installed
    —> Package perl-Encode-Detect.x86_64 0:1.01-2.el6 will be installed
    —> Package perl-Error.noarch 1:0.17015-4.el6 will be installed
    —> Package perl-ExtUtils-MakeMaker.x86_64 0:6.55-141.el6_7.1 will be installed
    –> Processing Dependency: perl-devel for package: perl-ExtUtils-MakeMaker-6.55-141.el6_7.1.x86_64
    –> Processing Dependency: perl(Test::Harness) for package: perl-ExtUtils-MakeMaker-6.55-141.el6_7.1.x86_64
    —> Package perl-Geo-IP.x86_64 0:1.38-6.el6 will be installed
    –> Processing Dependency: libGeoIP.so.1()(64bit) for package: perl-Geo-IP-1.38-6.el6.x86_64
    —> Package perl-IO-Zlib.x86_64 1:1.09-141.el6_7.1 will be installed
    —> Package perl-Net-CIDR-Lite.noarch 0:0.21-1.el6 will be installed
    —> Package perl-Package-Constants.x86_64 1:0.02-141.el6_7.1 will be installed
    —> Package procmail.x86_64 0:3.22-25.1.el6_5.1 will be installed
    –> Running transaction check
    —> Package GeoIP.x86_64 0:1.6.5-1.el6 will be installed
    –> Processing Dependency: geoipupdate for package: GeoIP-1.6.5-1.el6.x86_64
    –> Processing Dependency: GeoIP-data for package: GeoIP-1.6.5-1.el6.x86_64
    —> Package clamav-db.x86_64 0:0.99-3.el6 will be installed
    —> Package perl-Test-Harness.x86_64 0:3.17-141.el6_7.1 will be installed
    —> Package perl-devel.x86_64 4:5.10.1-141.el6_7.1 will be installed
    –> Processing Dependency: perl(ExtUtils::ParseXS) for package: 4:perl-devel-5.10.1-141.el6_7.1.x86_64
    –> Processing Dependency: glibc-devel for package: 4:perl-devel-5.10.1-141.el6_7.1.x86_64
    –> Processing Dependency: gdbm-devel for package: 4:perl-devel-5.10.1-141.el6_7.1.x86_64
    –> Processing Dependency: db4-devel for package: 4:perl-devel-5.10.1-141.el6_7.1.x86_64
    –> Running transaction check
    —> Package GeoIP-GeoLite-data.noarch 0:2015.04-2.el6 will be installed
    –> Processing Dependency: GeoIP-GeoLite-data-extra = 2015.04-2.el6 for package: GeoIP-GeoLite-data-2015.04-2.el6.noarch
    —> Package db4-devel.x86_64 0:4.7.25-20.el6_7 will be installed
    –> Processing Dependency: db4-cxx = 4.7.25-20.el6_7 for package: db4-devel-4.7.25-20.el6_7.x86_64
    –> Processing Dependency: libdb_cxx-4.7.so()(64bit) for package: db4-devel-4.7.25-20.el6_7.x86_64
    —> Package gdbm-devel.x86_64 0:1.8.0-39.el6 will be installed
    —> Package geoipupdate.x86_64 0:2.2.1-2.el6 will be installed
    —> Package glibc-devel.x86_64 0:2.12-1.192.el6 will be installed
    –> Processing Dependency: glibc-headers = 2.12-1.192.el6 for package: glibc-devel-2.12-1.192.el6.x86_64
    –> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.192.el6.x86_64
    —> Package perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-141.el6_7.1 will be installed
    –> Running transaction check
    —> Package GeoIP-GeoLite-data-extra.noarch 0:2015.04-2.el6 will be installed
    —> Package db4-cxx.x86_64 0:4.7.25-20.el6_7 will be installed
    —> Package glibc-headers.x86_64 0:2.12-1.192.el6 will be installed
    –> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.192.el6.x86_64
    –> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.192.el6.x86_64
    –> Running transaction check
    —> Package kernel-headers.x86_64 0:2.6.32-642.1.1.el6 will be installed
    –> Finished Dependency Resolution

Dependencies Resolved

Can this cause the problem in the software center? @alefattorini @davidep

warning: rpmts_HdrFromFdno: Header V4 RSA/SHA1 Signature, key ID 2bdaabff: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-NETHFORGE-6
Importing GPG key 0x2BDAABFF:
Userid : NethForge nethserver@googlegroups.com
Package: nethserver-nethforge-release-6.6-3.ns6.noarch (@extras)
From : /etc/pki/rpm-gpg/RPM-GPG-KEY-NETHFORGE-6
Is this ok [y/N]: Y
Is this ok [y/N]: y

3 Likes

I’m investigating it,
at a first glance it seems the NethForge key is not installed by Anaconda and the package perl-Expect comes (unexpectedly) from NethForge.

However we’ll need to fix the RPM GPG key import for NethForge. We’ll probably release a fix in the next days. In the meantime the command to workaround the problem should be

rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-NETHFORGE-6

Edit: opened a bug http://dev.nethserver.org/issues/3408

3 Likes

I will do the test adding the key and then installing from the software center

Thank you @davidep

1 Like

Please, wait a minute. I’m releasing an RPM that should fix the Software Center. Would you like to try it?

2 Likes

Perfect’ll be waiting.

The RPM is ready! After you’ve installed it, go back to Software Center page and try to install something from NethForge. Of course, you should not have already imported the NethForge GPG key!

yum localinstall http://packages.nethesis.it/nethserver/6.8/testing/x86_64/Packages/nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch.rpm
1 Like

Ok, Already installed, I just created a NethServer 6.8 in virtualbox:

[root@localhost ~]# yum localinstall http://packages.nethesis.it/nethserver/6.8/testing/x86_64/Packages/nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch.rpm
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Setting up Local Package Process
nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch.rpm | 212 kB 00:00
Examining /var/tmp/yum-root-qFklxH/nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch.rpm: nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch
Marking /var/tmp/yum-root-qFklxH/nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch.rpm as an update to nethserver-base-2.11.0-1.ns6.noarch
Determining fastest mirrors

  • centos-base: mirror.steadfast.net
  • centos-updates: mirror.steadfast.net
  • nethforge: nethserver.de-labrusse.fr
  • nethserver-base: nethserver.de-labrusse.fr
  • nethserver-updates: nethserver.de-labrusse.fr
    centos-base | 3.7 kB 00:00
    centos-base/primary_db | 4.7 MB 00:05
    centos-updates | 3.4 kB 00:00
    centos-updates/primary_db | 740 kB 00:00
    nethforge | 3.6 kB 00:00
    nethforge/primary_db | 14 kB 00:00
    nethserver-base | 3.7 kB 00:00
    nethserver-base/primary_db | 490 kB 00:01
    nethserver-updates | 4.0 kB 00:00
    nethserver-updates/primary_db | 1.2 kB 00:00
    Resolving Dependencies
    –> Running transaction check
    —> Package nethserver-base.noarch 0:2.11.0-1.ns6 will be updated
    —> Package nethserver-base.noarch 0:2.11.0-1.1.gcc981e5.ns6 will be an update
    –> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version
Repository Size

Updating:
nethserver-base noarch 2.11.0-1.1.gcc981e5.ns6
/nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch 575 k

Transaction Summary

Upgrade 1 Package(s)

Total size: 575 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch 1/2
Cleanup : nethserver-base-2.11.0-1.ns6.noarch 2/2
Verifying : nethserver-base-2.11.0-1.1.gcc981e5.ns6.noarch 1/2
Verifying : nethserver-base-2.11.0-1.ns6.noarch 2/2

Updated:
nethserver-base.noarch 0:2.11.0-1.1.gcc981e5.ns6

Complete!

Right now I’m doing the tests from the software center

3 Likes

Failure occurred from the center of Software @davidep







1 Like

Could you try to install SOGo from the command line to see the output?

yum groupinstall nethserver-groupware

If the error occurred from the Software Center, why from ssh installing each package says the opposite?

[root@localhost ~]# yum install nethserver-sogo
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Setting up Install Process
Loading mirror speeds from cached hostfile



Funny!

The command yum history <LATESTID> may help to investigate what went wrong!

[root@localhost ~]# yum history
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
ID | Login user | Date and time | Action(s) | Altered

 5 | System <unset>           | 2016-06-21 06:54 | Install        |  127   
 4 | System <unset>           | 2016-06-21 06:46 | I, U           |   15   
 3 | root <root>              | 2016-06-21 06:41 | Update         |    1   
 2 | System <unset>           | 2016-06-21 06:34 | Install        |  138   
 1 | System <unset>           | 2016-06-21 06:32 | Install        |  205   

history list
[root@localhost ~]#

It’s great fun, as we say here will be Blithe Spirit? :ghost:

@davidep But if there was a change before the upgrade rpm, the installation did not happen. and should be done from the terminal.

As you said SOGo is present, I was wondering if SOGo was correctly installed but some kind of other error occurred.

everything looks fine.

Run this command “yum deplist $(rpm -q nethserver-sogo)” to verify all dependencies and install each one to verify which is not installed

From the terminal does not give me any error during and after installation.

It may be a bug in the software center?

@fewfollower @painkiller895 Can you perform these tests and verify that is working its services SOGO?