IMAP Client auth issue

Hi All.

I cannot get IMAP Mail Clients - eg Thunderbird and Outlook - to authenticate to the server. They just show an error:
mail dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=, lip=, TLS, session=
They find the server and its settings correctly but fail to complete with the above error (from the /var/log/imap log) each time they try.

It is a clean install with just the Active Directory setup and the mail server and horde installed;
Horde works perfectly. I also tried running webtob and sogo and they also work perfectly via their webclient.

It is a standalone server without gateway.

I have tried connecting the client using IP addresses and domain name on the LAN and WAN;
It is a FQDN with correct routing and SSL installed.
Tried ‘username’ and ‘username’@‘domain’ all with the same result;

Any suggestions as to what I may be missing? The logs suggest the connection is correct, the clients suggest the username or password is incorrect (checked and double-checked).


NethServer Version: NethServer release 7.6.1810 (final)
Module: nethserver-mail-server

Is there any antivirus installed on the client, filtering email protocols?

Thanks for the suggestion Michael, but no. Connectivity and activity looks right by the logs.


I’ve had some success with this. Thunderbird connected by turning off connection security (TLS etc). Outlook is no longer that configurable.

Will play and check conf at the server end to make the process simpler and report back in.


1 Like

Certificate is self-signed or Let’sencrypt provided?

LetsEncrypt Michael, yet I’m going to uninstall/reinstall again as I may not have selected that as the default server cert (assuming it would just do so :frowning: )

Old Thread, I know.

Are you still using horde? You mentioned horde works perfectly with an AD. Did you customize any settings? What install directions did you follow?

Thanks for any reply.

Hi Stefan. No, not using it specifically any more. I think at the time it was a preferred client to Roundcube and was offered via nethserver-horde :

I then seem to recall that Horde was behind in providing PHP7 support which caused some issues. I wasn’t reliant on it so moved away from it. SOGo appears to have moved ahead of Horde by leaps and bounds.

Any reason you are wanting to use Horde specifically, or are you having any issues?


1 Like

Horde is still available in nethforge-testing but there were issues with TLS (you need to use older TLS policy), see Horde login problems - #5 by mrmarkuz

yum install nethserver-horde --enablerepo=nethforge-testing

Here is the PHP 7.3 PEAR install howto working with newest TLS policy:


Good morning Klaus,

thank’s for your reply. Well, many years back we started to use horde as groupware. I think it’s some kind of beeing lost in the past. Right now we’re using sogo which is quite o.k.

1 Like


also a big “thank’s” for jumping on. I’ll give it a try in a VM. I’ve a running NS configured with an AD. I’ll let you know how it works.