Howto install Odoo 10

Hi Clinton, welcome here. Please let us know how your tests go :slight_smile:

I tried to install it under Debian 9 and it has been working. Would be nice to have an unexpensive ERP-System under NethServer…

Do we have ERP-Experts here ?

1 Like

Did you try to install it on NethServer? Isn’t it similar to installing odoo?

No, had no time until now…

Pleas have a look (debian9):

adduser --system --quiet --shell=/bin/bash --home=/opt/flectra --gecos ‘flectra’ --group flectra
mkdir /etc/flectra
mkdir /var/log/flectra/
apt-get update
apt-get upgrade -y
apt-get install postgresql build-essential python3-pillow python3-lxml python-ldap3 python3-dev python3-pip python3-setuptools git libldap2-dev libsasl2-dev libxml2-dev libxslt1-dev libjpeg-dev zlib1g-dev curl -y
curl -sL | bash -
apt-get install nodejs wkhtmltopdf -y

git clone --depth=1 --branch=master /opt/flectra/flectra
chown flectra:flectra /opt/flectra/ -R
chown flectra:flectra /var/log/flectra/ -R
cd /opt/flectra/flectra
pip3 install -r requirements.txt
npm install -g less less-plugin-clean-css -y
ln -s /usr/bin/nodejs /usr/bin/node

apt-get remove wkhtmltopdf -y
cd /tmp &&
tar xf wkhtmltox-0.12.4_linux-generic-amd64.tar.xz
cp -R /tmp/wkhtmltox/ /

wget -N && gunzip GeoLiteCity.dat.gz && mkdir /usr/share/GeoIP/ && mv GeoLiteCity.dat /usr/share/GeoIP/
su - postgres -c “createuser -s flectra"
su - flectra -c “/opt/flectra/flectra/flectra-bin --addons-path=/opt/flectra/flectra/addons -s --stop-after-init"
mv /opt/flectra/.flectrarc /etc/flectra/flectra.conf
sed -i “s,^(logfile = ).,\1”/var/log/flectra/flectra-server.log”,” /etc/flectra/flectra.conf
sed -i “s,^(logrotate = ).,\1"True”," /etc/flectra/flectra.conf
sed -i “s,^(proxy_mode = ).*,\1"True”," /etc/flectra/flectra.conf
cp /opt/flectra/flectra/debian/init /etc/init.d/flectra
chmod +x /etc/init.d/flectra
ln -s /opt/flectra/flectra/flectra-bin /usr/bin/flectra
update-rc.d -f flectra start 20 2 3 4 5 .
service flectra start

1 Like

Running into some issues with this on a Neth 7.4 test VM. It started with creating the database:
postgres=# CREATE DATABASE odoo ENCODING 'UTF8' OWNER odoo; ERROR: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII) HINT: Use the same encoding as in the template database, or use template0 as template.
So I ran the create command without specifying UTF8. The remainder of the installation appeared to proceed without issues, but I’m getting an Internal Server Error when I browse to http://host:8069. In /var/log/odoo/odoo-server.log, I’m seeing this:
2017-12-15 22:57:59,098 4330 INFO odoo werkzeug: - - [15/Dec/2017 22:57:59] “GET / HTTP/1.1” 500 -
2017-12-15 22:57:59,105 4330 ERROR odoo werkzeug: Error on request:
Traceback (most recent call last):
File “/usr/lib/python2.7/site-packages/werkzeug/”, line 177, in run_wsgi
File “/usr/lib/python2.7/site-packages/werkzeug/”, line 165, in execute
application_iter = app(environ, start_response)
File “/usr/lib/python2.7/site-packages/odoo/service/”, line 246, in app
return, s)
File “/usr/lib/python2.7/site-packages/odoo/service/”, line 186, in application
return application_unproxied(environ, start_response)
File “/usr/lib/python2.7/site-packages/odoo/service/”, line 172, in application_unproxied
result = handler(environ, start_response)
File “/usr/lib/python2.7/site-packages/odoo/”, line 1308, in call
return self.dispatch(environ, start_response)
File “/usr/lib/python2.7/site-packages/odoo/”, line 1282, in call
return, start_wrapped)
File “/usr/lib/python2.7/site-packages/werkzeug/”, line 579, in call
return, start_response)
File “/usr/lib/python2.7/site-packages/odoo/”, line 1464, in dispatch
File “/usr/lib/python2.7/site-packages/odoo/”, line 52, in registry
return modules.registry.Registry(database_name)
File “/usr/lib/python2.7/site-packages/odoo/modules/”, line 59, in new
File “/usr/lib/python2.7/site-packages/odoo/modules/”, line 83, in new
odoo.modules.load_modules(registry._db, force_demo, status, update_module)
File “/usr/lib/python2.7/site-packages/odoo/modules/”, line 280, in load_modules
loaded_modules, processed_modules = load_module_graph(cr, graph, status, perform_checks=update_module, report=report)
File “/usr/lib/python2.7/site-packages/odoo/modules/”, line 156, in load_module_graph
_load_data(cr, module_name, idref, mode, kind=‘data’)
File “/usr/lib/python2.7/site-packages/odoo/modules/”, line 95, in load_data
tools.convert_file(cr, module_name, filename, idref, mode, noupdate, kind, report)
File “/usr/lib/python2.7/site-packages/odoo/tools/”, line 839, in convert_file
convert_csv_import(cr, module, pathname,, idref, mode, noupdate)
File “/usr/lib/python2.7/site-packages/odoo/tools/”, line 895, in convert_csv_import
raise Exception(
(‘Module loading %s failed: file %s could not be processed:\n %s’) % (module, fname, warning_msg))
Exception: Module loading base failed: file base/res/res.lang.csv could not be processed:
Unknown error during import: <class ‘odoo.exceptions.ValidationError’>: Error while validating constraint

1 Like

Thank you, you are right. Maybe a postgres update changed the behaviour. The solution is to make the db UTF8 using template0:


I’ll update the howto asap…thanks again!

That seems to have resolved it. A suggestion to simplify the instructions: When you’re installing the dependencies, only install nethserver-postgresql. Then, when it’s time to install odoo, rather than downloading with wget and manually adding the key, simply do yum install That will pick up all the dependencies, add the key if needed, and install everything.

1 Like

Thanks again, this way we can make one line out of four and required packages are handled by odoo package:

yum -y install nethserver-postgresql
1 Like

Hi Markus,

Have used the following with no errors being displayed

Were do i go from here with initial setup for https? from reading the Odoo instruction there using nginx is this possible with NS or will it break something?

Hi Clinton,

It’s possible but nginx and apache use the same ports by default so you have to change the nginx port 80 to something else or apache won’t start anymore. I didn’t try nginx with odoo yet.

Here is an example of installing nginx:

I am thinking that i’m starting to get ahead of my self with that question, I apologize. Will try again :slight_smile:

Odoo is multi threaded for multiple Users / Odoo Apps. As the NS community and the Dev team have put so much effort into such a stable Server OS i would like to avoid adding extra complexity by using untested non NS software and plugins etc…

Q: What is the best way in NS to have Odoo with multi threading on HTTPs using only what comes with NS (Apache, nethserver-httpd-proxypass, nethserver-lightsquid, nethserver-squid)

Sorry, I didn’t test it for now, maybe you could use the NethServer Reverse Proxy module (apache proxypass) instead of nginx. Squid is a not a reverse proxy, you won’t need it in this case.


I added HTTPS config in my first post but it does only work with installing nginx and move apache to other ports which may make other apps unusable.

Odoo can integrate AD users, the new nethserver-sssd update makes it really easy without the need of a seperate AD user! It’s included in the howto (first post)

1 Like

What do you think abt Odoo 11?

Odoo 11 should be stable now, has anyone tried to install odoo 11?

I tried just installing odoo 11 like odoo 10 but there are some python3 dependencies that couldn’t be resolved like

Error: Package: odoo-11.0.post20180115-1.noarch (/odoo_11.0.latest.noarch)
Requires: python3-stdnum

Maybe this can help: deajan commented 21 days ago

Thanks, I tried it but no success so far…

Some other links I found:

Thanks for sharing! Are you planning on writing a tutorial on Odoo 11 installation? The changes in each Odoo release are making it even better. You can see them on a picture here: I’m sure Odoo has a great future.

1 Like

Yes, it’s still on my todo list. I already tried to install it once but without success. I’ll keep you updated in this thread.


The new howto is here: