Howto install Odoo 10

Thanks for your feedback, I already did some changes like typos and yum install…

My testsystem was not that good, many packages installed, tested other software, so I’ll go through the howto with a fresh installation the next days…

Builtin server of Odoo just does http, so there’s another mission with nginx proxy:
https://www.odoo.com/documentation/10.0/setup/deploy.html#https

I created a user with phppgmyadmin without a database, so I got the db creation screen.
Maybe you did the command line way with creating role and db so no db creation screen, would make sense.
Important is the user, as user postgres is not allowed, it seems like the DB will be created, just when necessary.

Indeed, I used command line

I had no trouble getting Odoo installed, although it has broken Yum for some reason with “The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation.” now being displayed, No amount of clearing the cache will fix this :frowning:

Now if anyone can help how do i setup Neth Server email to work with Odoo and fix Yum? I would like to use this setup in a production environment.

Hi @Clinton_McDonald,

did you check this thread?

https://community.nethserver.org/t/the-install-update-may-have-failed-due-to-metadata-caching-problem/8382

Are you able to update via command line?

When I find time, I’ll try to setup mail in odoo and post my experience…

1 Like

This is another great application that uses PostgreSQL as database backend. SavaPage also uses PostgreSQL and there are probably several other applications that could be an enhancement for NetrhServer that rely on PostgreSQL.
Would it be a strange idea to have a NethServer-postgresql package to choose from in the standard category in SoftwareCenter? Anyone willing/able to make one?

Do you know this posting:
https://community.nethserver.org/t/postgresql-on-ns7/8233
Maybe you can work together… ?

2 Likes

Hi Markus,

Thank you for the reply :slight_smile:

yes tried all that from a terminal with no success, had a look for the log /etc/yum/vars/nsrelease its not there, there is a file /etc/yum/vars/infra with on entry in it “stock” this test server had been online and updating fine for over a month till i installed Odoo. im wondering if Odoo has pulled something in that has caused yum to fail. I will try this again with another fresh install and see what happens.

i have been using a Turnkey Odoo apliance with no email at all for the last couple of years, but would like to have Neth Server instead as i hopefully will be able to connect Odoo strait back to Neth Server for email all on one VM. this will be sitting behind another Neth Server acting as a reverse proxy and email forwarder/antivirus for several VM’s. Getting this running would give me somewhere so start.

Any help from you or any one can give would be awesome :slight_smile:

2 Likes

I confirm your HowTo is working as expected. Did the commandline way. Didn’t have to install psutil 2.2.1.

Great job Markus!!

2 Likes

When I find time, I’ll try it.

Thnx for the offer @mrmarkuz.
As @fausp already pointed out, there already is one. See http://docs.nethserver.org/projects/nethserver-devel/en/v7/nethserver-postgresql.html

1 Like

Is there anyone who is using odoo in production on NethServer?

Our Odoo is running on a Ubuntu 16.04 plattform in the same network ;-).

1 Like

Good to know! Any test on NethServer anyway?

no not at the moment

Me :wink:

2 Likes

i am using a Turnkey linux Odoo apliance “Debian” in production only the web site building module though as have not found a good solution for the email side of it. :disappointed:

I tried it now and could not reproduce it. Fresh 7.4, installed odoo and Software Center works.

It’s possible to setup SMTP and IMAP mail server in odoo. It seems also possible to add a custom template to postfix to use the local mail server directly.

Source:

https://www.odoo.com/documentation/user/10.0/discuss/email_servers.html

Thanks for testing! :+1: Although the issue with psutil happened only once, I’d like to keep it in the howto, maybe it helps others.

1 Like

Flectra a Fork of Odoo 10:

https://flectrahq.com
https://gist.github.com/flectrahqadmin

3 Likes