Howto install guacamole

In edge

same result in chrome

when i access from lan works

[Wed Aug 29 15:32:49.611370 2018] [ssl:error] [pid 26186] [client 190.143.227.251:9361] AH02219: access to proxy:http://localhost:8080/guacamole failed, reason: SSL connection required

I just view this error

this is my proxy conf

If you installed the module you don’t need to setup a separate reverse proxy in web UI, it’s all done by the module.

The reverse proxy config of the module should be in /etc/httpd/conf.d/guacamole.conf.

Ok that its was not clear for me, thanks

so, I delete on gui and then search the file conf

The guacamole.conf looks ok. Does it work now?

Maybe you need to restart the services:

systemctl restart httpd guacd

Sorry for make you loose your time with me, It was my mistake, I was a port forwarding config that was blocking the connection when I disable it, guacamole works fine.

Again sorry.

1 Like

No problem, glad it works now!

@mrmarkuz
Hello

I’m having problems on quite a lot of Guacamole NethServers recently.
Most will just show “Unexpected internal error” in red on top of the login screen.
Sometimes I also get a “Error while query user DNs.”…

All Guacamole Servers are using local authentification, not LDAP (so far).
No major changes on the servers besides the usual updates.

A couple of NethServers with Guacamole DO still work… (Maybe 10-20% of all my clients Nethservers with Guacamole)

Any ideas what’s causing this, or where to look for errors?

A reboot has helped - some of the NethServers have a few Months uptime…

Thx
Andy

Another common error:

This is despite the remote server being accessible with RDP or VNC…

I could not reproduce, please post which packages are installed on a not working server:

rpm -qa "nethserver-*" | sort

Please check /var/log/messages and /var/log/tomcat/* if you see some relevant errors.

The error indicates that LDAP/AD is used, this is strange. :thinking:

Instead of a reboot you may also try to restart the services:

systemctl restart tomcat guacd

Thank you to all contributors for sharing this information.