Howto install guacamole

Sorry for make you loose your time with me, It was my mistake, I was a port forwarding config that was blocking the connection when I disable it, guacamole works fine.

Again sorry.

1 Like

No problem, glad it works now!


I’m having problems on quite a lot of Guacamole NethServers recently.
Most will just show “Unexpected internal error” in red on top of the login screen.
Sometimes I also get a “Error while query user DNs.”…

All Guacamole Servers are using local authentification, not LDAP (so far).
No major changes on the servers besides the usual updates.

A couple of NethServers with Guacamole DO still work… (Maybe 10-20% of all my clients Nethservers with Guacamole)

Any ideas what’s causing this, or where to look for errors?

A reboot has helped - some of the NethServers have a few Months uptime…


Another common error:

This is despite the remote server being accessible with RDP or VNC…

I could not reproduce, please post which packages are installed on a not working server:

rpm -qa "nethserver-*" | sort

Please check /var/log/messages and /var/log/tomcat/* if you see some relevant errors.

The error indicates that LDAP/AD is used, this is strange. :thinking:

Instead of a reboot you may also try to restart the services:

systemctl restart tomcat guacd

Thank you to all contributors for sharing this information.


In using Guacamole I have the problem that the codepage (Keyboard) for Guacamole doesn’t seem to reflect the system settings of NethServer.

NethServer is set to use Swiss-German. The Remote-PC (A Windows 10 VM) is also set to use Swiss-German. However, when using Guacamole, the Keyboard seems to be fixed at english (USA).

Where can this be corrected?

I have read the following:
especially the part about and available-languages, but I can’t find where should I put these and in what form… (A custom Template?)

Otherwise - Guacamole works great for several sites…


I think in a custom template:

mkdir -p /etc/e-smith/templates-custom/etc/guacamole/
vi /etc/e-smith/templates-custom/etc/guacamole/

But if using RDP you might be looking for server-layout connection parameter (placed at user-mapping.xml).


Tried the Template (Using a different Nr…) expanded the template and it’s in the main config (/etc/guacamole/, restarted Guacamole / Tomcat but still doesn’t work as expected.

It seems the needed Swiss-german isn’t included, however Swiss-French is.
I’ve fed this into the Apache/Guacamole JIRA, and the reply was:
“Yep, it can definitely be corrected - just needs someone who knows the layout to implement it.”

It should show up in one of the next updates / fixes from Guacamole…



OK, here’s a related issue:

and the reported issue:


I compiled guacamole 1.1.0 (that should include the fix) and tested with W10 but Swiss German still does not work and I get the fallback to US English.

I can choose Swiss German in the guacamole client UI now (did not work in old version) but it seems not implemented in guacamole server yet.

1 Like


Was the keyboard file for Swiss-German included somewhere in the code for 1.10 (ch-de-qwertz.keymap)?

Thanks for the effort, I also wasn’t able to get it working, bur it seems others have…

Must look into it further…




Maybe it’s a “Windows 10” problem. Did you test other MS systems?


Yes, since I’m migrating the old systems to newer ones, I have quite a choice…
The Old Windows Server 2011 SBS, An old Client (Win7Pro), the new Server 2016, and a few PCs running Win10Pro.
I have Guacamole AND MS-RDP-Client configured for all machines.
The problem is with all OS so far.

BTW: The Nethserver on this site is the one having Zabbix Problems, the second NethServer I set up in this site doesn’t display those problems (Not marking Objects in the Map). Otherwise both work extremly well.

The Network looks like this now:


This Network is for a Doctors place, two Doctors, both Specialists in Arthros (Having to do with Limbs, artificial joints, and such). They have an X-Ray, a Mac running Horos as Dicom PAC (X-Ray Picture Archive). The software used is Windows based, the Mailserver is Kerio. Kerio used to run on the Mac Server (gone), then on Windows 2011 SBS, now it’s running on a Centos Container in ProxMox.
The Clients are Mac Minis, running Parallels and now Windows 10 Clients. The IPs of the Parallels Clients are ten higher than the corresponding Mac Minis they actually run on, eg Mac=, Win10=

All older Win7 clients are still fully available, but aren’t anymore on this Zabbix Map.
The AD is based on NethServer, so is DHCP and DNS. A Raspberry does ups support and shuts down the Proxmox (Including the VMs) and both NAS and the Mac running Horos.
Horos is OpenSource Software (A Fork of Osirix) that is a DICOM Viewer and also a PAC for Horos.
All Backups are consolidated on the Synology NAS, and synched to the Doctors Place in Zürich (One of the Doctors has a second place in Zürich) where the same model of NAS stands. Both have an additional Disk just for this cross-site synching.

NethServe also handles all http and https access from the Internet, a reverse proxy forwards Webmail to Kerio.

UPS in Zabbix, with SNMP monitoring of NUT:

I’m releasing this information to help others in this Forum see how and what the ideas behind a simple to complex setup based on NethServer could look like.


1 Like

Guacamole seems to work now with Swiss German, my test system used the old guacd. With guacd 1.1.0 I don’t get the fallback to English anymore. I can use Swiss German now, even if English is set as system default on Windows.

guacd[12619]: INFO:     Loading keymap "base"
guacd[12619]: INFO:     Loading keymap "de-ch-qwertz"

I’ll try update the module to the unstable 1.1.0 and go stable as soon as guacamole 1.1.0 is released.

BTW, nice scenario, thanks for sharing!


Thanks for your cool modules, Guacamole & Zabbix, and your great help!

Will the update show up on the internal NethServer Updates?


No, I’ll report here when it’s finished to test it before providing it as update.

1 Like

OK, Thx!

Have a good night!

Oder auf gut Schweizerdeutsch:
Es guetes Pfüsi!


1 Like



Is it possible to change the OpenJDK version of Java to the “official” v8?

Necxtcloud Fulltextsearch needs Java v8 for this…

Thanks for any feedback!


Are you sure? IIRC I tested with openjdk and it worked.

Will test again.
What version of openJDK are you using?
I think mine’s 1.7, but I’ll need to double check later…

PS Does todays Guacamole Update include the CH-German Keyboard ?