How to setup allow email with hostname in email address?

Just installed NethServer 7.9.2009

There is no problem with the email sent to an address with DomainName.
But system rejected the email to an address with Host Name instead of Domain Name

The email log say : Recipient address rejected: Access denied

How could I change the setting to accept either one?

Thanks!

@Luzern

Hi Bryan

And welcome to the NethServer Forum!

Are you, by any chance, from Lucerne in Switzerland?
(See my “Tag” on the top left of any of my posts…)

Email, is something invented in the 70ies for the Internet - and it’s still one of the major use protocolls for communication today. Unfortunately, spam is a large part of this, but that’s another story!

In any case, mail was designed for the Internet, and as such, it needs (AFAIK) a domainname after the “@”.
It wasn’t designed for Windows systems, which often only use the hostname, limited to 15 CHRs…

AFAIK, NethServer won’t accept a Domain without a dot in it.

My 2 cents
Andy

@Andy_Wismer

:grinning: Not from Switzerland, but been there and like Lucerne.

Say, the hostname of my Nethserver box is mail.mydomain.com
Now, email to abc@mail.mydomain.com is rejected, and abc@mydomain.com is OK.

I want to config the box to accept both email address format.

@Luzern

Hi

You can add in additional “domains” (Even if pointing to the same server!) here in Cockpit, under Applications -> Email -> Domains -> Create new…

You should also have a dns entry internally and externally for this… :slight_smile:

My 2 cents
Andy

Added mail.mydomain.com but no help.

message in log file:

Jul 30 15:47:31 mail postfix/smtpd[21323]: NOQUEUE: reject: RCPT from unknown[192.168.12.10]: 554 5.7.1 xxx@mail.mydomain.com: Recipient address rejected: Access denied;

@Luzern

Hi

You also need to add in eg xxx@mail.mydomain.com as a valid email alias… :slight_smile:

The aliases do not automatically get replicated over all domains…

If xxx@mail.mydomain.com is not in the reciepient list, the mail gets rejected.

My 2 cents
Andy

1 Like

After perform what @Andy_Wismer’s recommended and study the following post:


It’s finally work after enable the SystemUserRecipientStatus.

config setprop postfix SystemUserRecipientStatus enabled
signal-event nethserver-mail-server-save

But this still not what I want, as I am going to install TWO NethServer
The first one is mail.domain.com, as my mail server, where the MX record point to.
The second one is abc.domain.com, which is used for testing projects and for receiving emails for the project. That’s why I want the domain part of the email address to be @abc.domain.com

Now, I will set the second NethServer as test.abc.domain.com. Then the domain part of the email address will be as @abc.domain.com

Dummy, but work :grinning: :grinning:
Thanks a lot!

@Luzern

Hi

On the first NethServer, the one actually recieving the mails from Internet, you can change the Domain “abc.domain.com” from local to remote, and use the IP of the other NethServer…

For outgoing Mail on the 2nd NethServer, simply use the first NethServer as smarthost.
Create a user on the first NethServer (eg smtp-user-abc), and use that for authentification when sending.

My 2 cents
Andy

1 Like