How to recover from CentOS7.4 samba /w. shared folders

Good morning everybody

after a half year of successful operation in production with our NethServer I ran into the problem described in

I ran the update Saturday in the mornig and I was completely unaware that this update could leave me without access to data from my windows clients. It was some hours later that I fount the before mentioned post and at about 3pm when I recived an email warning to NOT UPGRADE, but then it was already TOO LATE!

My solution was to set up a computer as a NAS with openmediavault and to copy all data from the shares from nethserver to the nas. At least the work of yesterday Sunday paid off as we have access again to our data.

Do I understand it right, that this is a bug from RHEL as the source code is used for CentOS? As far as I understand the not functioning access was already known some weeks ago. Why are those packages cleared for update on nethserver?

In my opinion it would be a good idea

  • at least show a warning message (maybe the one that is in the community forum) on top in the “software center” page. If I had seen this message I would certainly not have updated my server
  • or even disable the update button, when an available update is likely to break some functionality

I always ran the updates with some precaution, checking what packages are going to be updated, and do also updates on Saturday so that I have some time to resolve in case that a problem occurs. After that all prior updates on nethserver were successful I did not have an idea that this one would cause troubles.

Do you have any idea when a working solution will be available? I will have to fix my now broken nethserver (at least the filesharing part of it) and then copy back all the data to nethserver.

Thanks for your Answer


Hi @mduerig,

did you try this?



The bug was known only from upstream but they decided to release anyway.
NethServer uses upstream repositories, there is a go/non-go policy for upstream packages.

There is a way to restore using the yum history feature?

This works for me

1 Like

Hi @EduardoGCorrea,

please mark an answer as solution, if your problem is solved…


You can update to latest packages, including the fix: