HotSync issues and features

I want to make a post where I update all issues and feature status about HotSync package.





  • httpd-admin is disabled on the target IMO is correct. Users won’t be able to do changes on slave host. We should also block access to Cockpit if is not HotSync app on slave host.


  • sometimes users of Maria database are not correctly restored to the destination machine :question: I can’t reproduce this issue. Probably solved: I added a sync of mysql tables containing users.
  • hotsync-slave fails if Owncloud is installed, the admin should commend the ’ exclude from yum.conf :question: I installed NextCloud from Software Center and no problems
  • permissions on c-icap :question: No problems on my installations

I will update it when I’ll change.

:white_check_mark: SOLVED
:ballot_box_with_check: TESTING
:question: NEED MORE INFO


Hi @federico.ballarini
Just to let you know, I (and I think this counts for the rest of our community) absolutely love the way you are devoted to make NethServer a better project. I want to thank you and hope you keep that spirit in the new year. Most importantly: have fun doing this!
best regards,


@flatspin Have you got problems with c-icap and ufdbguard permissions? I can’t reproduce the problem.

First I also want to say thanks to you, for your efforts for this project! :smiley:

As fa as I can remember i had no problem with ufdbguard or c-icap service. I had the vmail ownership issue and my systemd targets were a bit messed up, so nsdc doesn’t start after disasterrecovery automatically.

And I had some problems with the repo config and this can hit a lot of installations.
One thing which can be common is, that the master machine has a subscription and the slave doesn’t have. The repo files are synced, so the sb-repos are used for the recovery. If the machine is updated before there can be a package conflict.
Also if packages are installed from neth-forge or stephdl or what ever repo, it is mandatory to enable this repos, otherwise the restore config script will fail.
So to maintain the repo config properly will save a lot of time in case of a dissaster recovery. But I don’t see a way to automate this.


Thank you for your answer. Now I’m working on permissions. I set as “not reproducible” the bug of ufdbguard and c-icap permissions (if we can reproduce in future we will fix it).

If you can, we have to test issues with :ballot_box_with_check: on the first post.

To test it: yum clean all && yum update -y nethserver-hotsync --enablerepo=nethforge-testing

Last package should be nethserver-hotsync-2.0.3-1.14

Please post here your results :slight_smile:
Remember that permissions will be set after hotsync-slave command (I also add auto launch before hotsync-promote command)

@flatspin NSDC status should be now ok. If you can test it please :slight_smile: You can help me a lot!

/cc: @mrmarkuz @dnutan @robb

If someone has info about “INFO REQUIRED” issues please post here. I can’t reprodue these issues.