Hosting on Server4you

Hi there!

I have tried to install the latest nethserver on a new server at server4you. I chose the CentOS minimum installer, after that i logged in as root and installed nethserver with:

yum update
yum localinstall

It looks all fine but in the end the server is no more reachable, no ping etc. If i reboot the machine, the ping and ssh is working again, after login it says “this is a nethserver installation…” but the webinterface on http or https also on :980 is not reachable.

Does anyone know if this could be working with a hosting provider?

My best guess is that Anaconda is tricking you and sets a default IP address on your network interface. If DHCP is not available NethServer defaults to
Maybe this discussion can shed some light: Set LAN IP after install

If you have SSH / Terminal access to the server you can manually configure the network interface:

db networks setprop YOURINTERFACENAME ipaddr DESIREDIPADDRESS netmask role green
signal-event interface-update

Then you should be able to acces the admin webinterface through https://DESIREDIPADDRESS:980
The IPADRESS should be known by your VPS host.

If you do have SSH access, but no webinterface, can you check if the httpd service is running?

I am not familiar with Server4you, but I have NethServer running on a Contabo VPS.

Hi Rob!
Thank you for the quick reply, after a reboot the server has the public ip on venet0:0 interface and is reachable with ssh and ping.

service httpd status
says it is active (running)

Now the server is reachable on port :980 but i can’t ping anything there. On network config i don’t have an eth0 interface…


UPDATE: i have added the public DNS servers in the dnsmasq.conf, now it’s working.

Thanks for the info, could you also please mark topic as solved.