Help with Samba Share not being available to clients

server ip:
ad ip:
FQDN: sensei.lsd.local
workgroup: lsd.local
share: test
user: john
group: general
The user’s group has permission to the nethserver-samba application.

I am unable to mount or explore any Samba share from a client in the same subnet.

The following works when run on the server itself: smbclient -L localhost -U'john'
But i get the following error if run from from a client in the same subnet:
smbclient -L -U'john'
I’ve tried variations of this command as well but nothing has worked.
The same is equally true if i try to mount with mount -t cifs -o username=user // /mnt/tmp
I have also tried to create a share with guest/anonymous access allowed but am still unable to initiate a null session with smbclient. I’m sure it’s something easy but i’ve been scratching my head for a while now.

Any help is appreciated, thanks

Could you try to check these services and restart them: sssd, smb, winbind, nsdc. Restart them one per time and check if starts working.
Recently I created a dc from cockpit without errors, bui I had to restart Winbind to get dc starts working.

1 Like

Thanks for the suggestion.
I experienced something similar in my last install, with cockpit errors and then winbnd wouldn’t start.
I ended up doing a fresh install and didn’t experience that this time.
All services look good this time but I went ahead and restarted sssd , smb , winbind and nsdc per your suggestion.
All started cleanly and there are no errors in the logs (log.smbd, log.nmbd or log.winbindd)

I did find some additional logs at /var/log/log.wb-BUILTIN and /var/log/log.wb-SENSEI and /var/log/log.wb-LSD and all three of the them contain the same message (error…?) :
[2020/01/13 16:42:53.079797, 0] ../source3/winbindd/winbindd.c:244(winbindd_sig_term_handler) Got sig[15] terminate (is_parent=0)
EDIT: those additional logs are from restarting the services. disregard

Anonymous access is working now.
I’ll keep digging

1 Like

Ok. What is not working?
And how are you trying to access?

I am accessing with smbclient to test first access first, then mounting with cifs-utils. It’s working now!
Ultimately It must have been restarting the services that fixed it.

1 Like

Well… It WAS working. Now it’s not again.
Nothing’s changed. Weird…