Help with Nextcloud today's update!


this is not working for ARM architecture. The package nextcloud-10.0.2 does not exists …

Probably it has to be compiled manually.


I would open a new topic about that :slight_smile: What do you think?

Please see the attached pictures.
If I do the updates, for Nextcloud I will encounter the same problem as .
After that I will do as @dnutan said and I will have Nextcloud functionally.

Of course, after that, the Nextcloud update will be there again, in the Software Center!

But maybe tomorrow we will have other updates, including the bad for Nextcloud, and we will start from the beginning: all updates, remove Nextcloud, install Nextcloud …

If we know that one or many updates can make trouble, for now, we can not select which updates are good and which updates are bad.

I think we should go back to this topic:
How to effectively communicate NethServer packages update?
( How to effectively communicate NethServer packages update? )

What do you think about that?


Wait a minute… why aren’t we pulling this update? If it’s broken we shouldn’t be pushing it.

1 Like

I opened a new topic yesterday yet under development …
I figured out that the new nexcloud package is compiling well under arm but php 5.6 is not available for arm :frowning:

I checked the dependencies of nextcloud and it seems to be a bigger project. I’m not so close with an arm build environment - cross compiling would be much better because of the raspi needs to much time for compiling.


Agree the Software Center could be improved.

For now as a workaround we can edit the epel repo file (/etc/yum.repos.d/epel.repo) and add exclusions under the [epel] section:


I have the same problem and I need to get my Nextcloud working. Shall I better wait for the update or do the uninstall/install? What is the expected timing, knowing that I don’t want to lose anything, of course.
Thank all of you.

For now:

1 - uninstall/install
2 - workaround:

Thank you, I’ll do that.

1 Like

You are welcome!


Done, but I still get the same error :disappointed:
Any idea?

After uninstall/install?

Not really, after 1 & 2. I haven’t tested in between

After “1” should work.
After “2” should not exist update for Nextcloud in Software Center.

When I uninstall then re-install, I should get the latest version, which gives the bug. Isn’t that logic?

No, you will have nethserver-nexcloud 10.0.2, not version from EPEL (10.0.4-1):

yum remove nextcloud
yum install nethserver-nextcloud nextcloud-10.0.2

1 Like

I did 1 through the Software Center, which installs nethserver-nextcloud.
I’ll do it through yum

I forgot to mention but is written in @dnutan post.

It works, thanks again!

1 Like

Works pefect. Thank you @dnutan and thank you all!

1 Like