Help with mounted folders


#1

I’m using Nethserver 6.7 and need a few folder mounted from my NAS. I did put the code in the FSTAB and when I run mount -a the Folders are perfectly right mounted.
After a reboot they are not mounted and I need to run the mount command manualy. They are still in the FSTAB.
One of the Folders is a iscsi connection 2 others are NFS shares.
I tryed to run mount -a in rc.local but this did’nt help either.

Could please someone point me into the right direction how to get the folders mounted automaticaly after reboot?


(Alessio Fattorini) #2

Can you show us your fstab? How did you edited it?
BTW welcome on NethServer Community!


#3

Hi Alessio,

that’s is my FSTAB:

`/dev/mapper/VolGroup-lv_root    /       ext4    defaults,acl,user_xattr 1 1
UUID=1387d0ce-686c-4b26-9bf7-566bbe27d0b5       /boot   ext3    defaults        1 2
/dev/mapper/VolGroup-lv_swap    swap    swap    defaults        0 0
tmpfs   /dev/shm        tmpfs   defaults        0 0
devpts  /dev/pts        devpts  gid=5,mode=620  0 0
sysfs   /sys    sysfs   defaults        0 0
proc    /proc   proc    defaults        0 0
UUID=e61522b6-8f82-4e76-8663-36b4ca007f59 /var/www/html2 ext3 defaults,_netdev
freenas.lan:/mnt/Speicher/backup/ftp-gateway/   /var/lib/nethserver/ftp/srv_ftp/ablage  nfs     defaults
freenas.lan:/mnt/Speicher/backup/linux/nemo_neu /mnt/backup     nfs     defaults`

I edited it with vim by just writing into it.

without the _netdev option I’ll get an error during boottime.


#4

hi,
is netfs enabled?

$ chkconfig --list netfs

#5

hi, no, ist not

chkconfig --list netfs netfs 0:off 1:off 2:off 3:off 4:off 5:off 6:off

how do I enable this?


#6
$ chkconfig netfs on

i would add the _netdev option also on nfs mount
then reboot…


(Artem Fedai) #7

Hi to all, I suppose that custom template of FSTAB should be created.


#8

thank you all this is a great help.
BUT:
after a reboot I’m having now my iscsi mount. but none of the nfs shares
during reboot I’ll get an connection timeout error on mount nfs.
to me it looks like this happens becos the shorewall starts after the netnfs service (accordingly to the boot.log)


(Artem Fedai) #9

@pnemenz,

According to http://shorewall.net/ports.htm#NFS, you should create firewall rule for NFS service, please run the following:

config set NFS service TCPPorts 111 UDPPorts 111 access private status enabled

#10

Thank you all for your Support.
The last problem, the timeout at boot time was not relatet to nethserver.
My NAS, freenas, does a reverse DNS lookup during the mount process. Apparently the DNS-Server is’nt startet at this time.
The solution is to add the nethserver to the freenas hosts file.